Help - Search - Members - Calendar
Full Version: Raid Devices - Superblocks Not Read
Linuxhelp > Support > Technical Support
eliroven
Hi guys and gals.

I have a big problem - I have been locked out of my machine...

On Startup I get the following message:

"Starting up RAID Devices:
Checking filesystems
fsck.ext3/dev/hdd6:

The superblocks could not be read or .../...
you might try running e2fsck with alternative superblocks
e2fsck -b 8193 <device>"

When I do this (which I dont really understand what it all means),
replacing <device> with /dev/hdd6 I get the message:

"No such file or directory".

I am running Mandrake 10.0 and it has worked a treat since
re-installation over 3 months ago. I have not installed any fancy RAID
software or apps. (that I know of) and this problem happened since I
removed a slave drive that was in the machine (but to my knowledge
doing nothing). I have tried replacing the slave drive (after
reformatting it for other use, though) but get the same problem.

Can anyone guide me in the right direccion to solve this problem - I
am locked out of my own machine Sad I tried google, but there was no
mention of how to fix this problem, but rather how to install RAID for
the use of multiple HDs.

All I want is to disable this RAID thing as I am only using one Master
HD with my Mandrake and Windows XP (the latter is working still) or get to some relevant file where it refers to hdd6 to point to somewhere else as I think hdd6 is the HD I removed and is looking for it now.

Thanks for your help

Eliroven
Termina
I removed your other posts. Please edit your above post and tell us the problem.
Hemant
Are you actually using RAID devices?
DS2K3
It might be an idea to boot with a LiveCD (ubuntu is a nice one, but ny should do) and then mount your disks. Once you ahve done that, post the output of your /etc/fstab file (the one that would be used when you boot normally, not the one being used by the LiveCD). It might just be a case of commenting a line.

D
eliroven
Hi again guys and gals.

Thanks for the help.

Hemant:
No, I am not using RAID, that is why I was so surprised and annoyed that something I was not even making use of, was messing my system up.

DS2K3:
You are right on the ball.

I just went into the fstab and removed the line making a reference to hdd6.
Basically I deleted the following line:

/dev/hdd6 /mnt/linux ext defaults 1 2

This simple action absolutely cured the problem and saved me from major headaches and aeons wasted.

Thanks again and bye for now.

Eliroven
DS2K3
Glad it's working biggrin.gif

* Resolved so closing *

D
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.