Help - Search - Members - Calendar
Full Version: Mouse Problems.
Linuxhelp > Support > Technical Support
G-VIRUS
When I was installing Linux Mandrake 9.1 it asked me to set up my mouse, I picked Microsoft Intellimouse (kind of mouse I have), and tried all the COM ports but none of them worked.
I continued installation, but now I can do barely anything with just a keyboard, and can't navigate the control panel to try to fix my problem. The weird thing is I have tried several mouses so I know mine works, and the mouse light turns on when my computer is booting up but right when it boots into Linux the light turns off.

Any help would be greatly appreciated. smile.gif
chrisw
is your mouse a ps/2?
G-VIRUS
USB, and I tried the PS/2 adapter, another USB mouse and a regular PS/2 mouse.
Corey
If you are switching between the USB Mouse and the USB/PS/2 adapter, you need to make sure that everything is configured right.


For PS/2 Connection:

In your /etc/X11/XF86Config-4 file, make sure that in your INPUT section, the mouse device points to /dev/psaux and that the Protocol is "PS/2".

For USB Connection:

You need to make sure that your USB subsystem is up and running, most times a distribution like Mandrake and Redhat will do this automatically. The device to access a USB mouse is most likely "/dev/input/mouse", to test to see if the system is reading the mouse, type:

QUOTE
cat /dev/input/mouse


...and move around your mouse, you should see a bunch of garbage characters fly accross the screen, this shows that your mouse is in working order. In that case, you can edit the file mentioned above in the same section and change the device to /dev/input/mouse .
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.