Help - Search - Members - Calendar
Full Version: Postfix Problems
Linuxhelp > Support > Technical Support
Jim
I would just like to start this post by saying IRC is useless, so lets see if you guys can be of any better use.

I just installed a postfix server on my CentOS box. Now I get this error in the logs any time something tries to connect on port 25.

CODE
Aug 17 21:36:36 localhost postfix/smtpd[2358]: fatal: SASL per-process initialization failed
Aug 17 21:36:37 localhost postfix/master[2314]: warning: process /usr/libexec/postfix/smtpd pid 2358 exit status 1
Aug 17 21:36:37 localhost postfix/master[2314]: warning: /usr/libexec/postfix/smtpd: bad command startup -- throttling


Anybody have any guesses on where I need to be looking for what to fix?
Termina
Blasphemy! *throws holy water on him*

I suppose the large IRC channels are worthless, though. wink.gif

Is this running in a chroot enviornment? (I know debian does, which can be a pain in the ass)

It might be a problem with postfix + it's version of your hosts file. (I had a similar error, and making sure my two hosts files worked fixed it).

Is this error in /var/log/mail.log? Or in another log file? mail.err might give you more information if mail.log doesn't

Does 'postfix check' come up with anything?

It's a shot in the dark, but "per-process" seems to suggest a problem with your limits.conf file (nproc).

'postfix -vv' might be helpful as well
Jim
I fixed it. and IRC sucks.
Termina
Not going to tell us how you fixed it, in case we ever run into this exact problem? wink.gif
Jim
Lets just put is this way,if you actually follow the instructions on the install guide you wont run into the problem.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.