Help - Search - Members - Calendar
Full Version: Internet Connection
Linuxhelp > Support > Technical Support
mitico boltzmann
Hi all, I installed MandrivaLinux 2005 LE on my PC and I have a problem: I can't get on the internet.
Better, I can get to the internet just for a minute after I open the session, then all the connection are unavaiable because the browser cannot get the host name. I controlled all the drivers and they seem to be correct.
Thanx All

Bye
mitico boltzmann
I add a little bit of information about my problem:

Before Internet Connection
[root@localhost ~]# ifconfig eth0
eth0 Link encap:Ethernet HWaddr 00:11:2F:E4:5D:71
inet addr:192.168.1.2 Bcast:192.168.1.255 Mask:255.255.255.0
inet6 addr: fe80::211:2fff:fee4:5d71/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:807 errors:0 dropped:0 overruns:0 frame:0
TX packets:672 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:66258 (64.7 Kb) TX bytes:51899 (50.6 Kb)
Interrupt:16 Memory:cfefc000-0

After Internet Connection with Mozilla Firefox
[root@localhost ~]# ifconfig eth0
eth0 Link encap:Ethernet HWaddr 00:11:2F:E4:5D:71
inet addr:192.168.1.2 Bcast:192.168.1.255 Mask:255.255.255.0
inet6 addr: fe80::211:2fff:fee4:5d71/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:2023 errors:1 dropped:0 overruns:1 frame:1
TX packets:1865 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:272425 (266.0 Kb) TX bytes:151426 (147.8 Kb)
Interrupt:16 Memory:cfefc000-0


Then the browser told me that it cannot resolve the host, etc...

And this are the result of pinging my gateway and a www address

[root@localhost ~]# ping -c 50 192.168.1.1 {Gateway Address – got with “route -n”}
PING 192.168.1.1 (192.168.1.1) 56(84) bytes of data.
From 192.168.1.2 icmp_seq=10 Destination Host Unreachable
....It is the same: just the number icmp_seq changes...
From 192.168.1.2 icmp_seq=50 Destination Host Unreachable

--- 192.168.1.1 ping statistics ---
50 packets transmitted, 0 received, +33 errors, 100% packet loss, time 49011ms
, pipe 3

The communication with my IP is OK.

I also tryed
[root@localhost ~]# ping -c 20 -n www.google.it
ping: unknown host www.google.it

a friend told me it could be a problem inside the linux server with the communication to the router.
Hope you can help me, bye
michaelk
What type of broadband service are you using?
Do you have a router? What is its make and model number?
Are you using a static or dynamic IP address?
mitico boltzmann
I am using a DSL with PPPoA connection type
I have a 3Com Office Connect ADSL Wireless 11g Firewall Router (my computer is connected via LAN, not wireless), model:3CRWDR100A-72
Not sure but I think i'm using a dynamic ip address, i'm using a dhcp protocol.
michaelk
Can you ping the router prior to using firefox to access the internet?
Are you running a firewall? What are it's settings?
Try disabling it and see what happens.
If that doesn't work then I would try disabling IPv6.
mitico boltzmann
This is the result of pinging my router (before trying to access the internet): Linux just started

--- 192.168.1.1 ping statistics ---
50 packets transmitted, 47 received, 6% packet loss, time 49063ms
rtt min/avg/max/mdev = 1.165/11.460/21.226/5.993 ms

And this is the result after 2 minutes the booting of Linux:

--- 192.168.1.1 ping statistics ---
50 packets transmitted, 0 received, +33 errors, 100% packet loss, time 49021ms
, pipe 3

It always said that destination Host was unreachable.

I am behind no firewall!

How can I disable IPv6?
michaelk
To disable ipv6 add to the /etc/modprobe.conf the following:
alias net-pf-10 off
alias ipv6 off

Need to be root to edit files in /etc/ directory
DS2K3
Check you aren't running the "lisa" service, I found that it caused my netowrk conenctions to break after a few minutes. (Have a look in the "System" -> "Enable and Disable System Services" area of DrakConf)

D
mitico boltzmann
To michaelk:
I tryed modifying the modprobe.conf file, but nothing changed

To DS2K3:
I didn't found any lisa service loaded in my system service
Newbie4
I had a similar problem which was resolved by insuring DNS (primary and secondary) addresses were in the /etc/resolv.d file. Check your DNS settings.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.