Help - Search - Members - Calendar
Full Version: Wireless Network
Linuxhelp > Support > Technical Support
doslucky
Yesterday I decided to put one of my old hard drives into my computer, as a secondary drive.
I then decided to put Mandrake/Mandriva Linux on it.
So I've got 2 hard drives. One has Windows XP on it(which I'm using to make this thread), and one with Mandrake/Mandriva on it.

I'm really new with linux, I had tried it once about a year ago, and succesfully got the internet working, but then shortly went back to windows.

Anyways, I can't figure how I got the internet working before, and I'm getting a little frustrated with it now.

I have a Netgear MR814v2 Wireless Router
I've got a USB-Firewire Netgear MA101 Adapter(The cord has a USB end which plugs into the computer, and a firewire end which plugs into the adapter)

So when I enter ifconfig in the terminal, it shows eth0, and eth1.
eth0 is an ethernet card in my computer that I've never used
I think eth1 is my netgear adapter, as somewhere in the description of the ifconfig it said IEEE(firewire).

But I can't connect to any web pages, and I really don't know what to do.
Termina
ifconfig wlan0 scan

Does that show anything?

Otherwise, you might want to put ndiswrapper on a disk (or CD-R) and install that. Chances are it'll work with your drivers (still got your CD laying around? wink.gif)
doslucky
ifconfig wlan0 scan did nothing, same with eth1.

Okay so I looked at a list of detected hardware, and under ethernet I found MA101 Wireless Adapter, so I know it's detecting it.

I'm going to burn ndiswrapper onto a disc now and I'll make another reply to let you know how it turns out.
Termina
That's my bad, I meant to say 'iwconfig'
doslucky
Tried that too.

Okay so I got ndiswrapper installed, I got the driver setup with it. But when I go into the computer settings and click setup new connection > wireless connection > use windows driver with ndiswrapper > use current driver(ma101 - which is the one i installed), and it gave me this:

insmod'ing module ndiswrapper failed at /usr/lib/libDrakX/modules.pm line 66

So I went to that directory, opened modules.pm, at line 66 it was just some code making a popup that says "insmod'ing module <module here> failed"

Are you sure I need to do this? I know the system detects the adapter, I just can't figure out how to get it to connect to my router.

P.S.
I'm gunna jump into yer IRC server whenever I can as |SnG|infliction
doslucky
Okay so this is where I'm stuck:

# modprobe ndiswrapper

FATAL: Error inserting ndiswrapper (/lib/modules/2.6.11-6mdk/kernel/3rdparty/ndiswrapper/ndiswrapper.ko.gz): Operation not permitted
Termina
Are you doing this as root?

Also, if you're able to idle on IRC, that would be convient. xD I usually check back a few times every hour, to see if anyone is talking. I missed you by a few minutes last time.
doslucky
Yep, doing it as root.

andrew from irc asked me to check if CONFIG_MODULES=y, and it does.
Termina
What distro are you using? Have you modified your kernel?

I assume you're using source, and not pre-compiled ndiswrapper for your distro. Any reason for this?

lsmod | grep ndis

Do you see anything?

Otherwise, please ensure that you have your kernel headers in /usr/src

Take a look at /var/log/messages (grep for ndis)

Still, chances are, your problem will be solved by using the ndiswrapper your distro provides to you. smile.gif
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.