Help - Search - Members - Calendar
Full Version: Samba Sharing
Linuxhelp > Support > Technical Support
Chris-RHS
I have setup sharing from my linux machine to my window machine using samba. I can view the directories, and everything seems to be working just fine, except for the speeds. It is very slow when just browsing the directories, and when transferring files to and fro. Is there something that can be done to speed things up?

thx
Corey
When you talk about the speed issues, how much time are we talking here? Seconds? Minutes?

I have a linux server that shares directories with samba, and it's pretty responsive. If it's really slow, you may want to check log files on the servers for error messages or warnings.
Robert83
Hi,

also if you are using Windows XP, I highly reccomend going into the administrative tools, and turning of the following service, Webclient.

after I turned it off...browsing the network neighbourhood in a samba domain ('n workgroup) was much more faster...as well as opening shares...


Sincerely
Robert B
Termina
If this is a new problem (samba was working well before, but now it's sluggish), try this:

Open up SSH, and log in as root (to the samba machine).

ps -A

Do you see a lot of smbd's or nmbd's? If so, just restart samba and it should work again.

(If you want, you could make a cron task to do this for you)
as2100
Also, in your smb.conf, there are a couple socket options that can really make the difference between night and day.

Try adding this to the smb.conf:
socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192

Could even try increasing the buffer size to 24K (or higher). I recently boosted my buffer size to try and get cleaner video from a linux share on my Windows workstation. This did the trick for me. smile.gif
Chris-RHS
Thanks for the tips, I disabled the windows service, and the improvement was minimul, I will try the other replies as well!
Chris-RHS
Ok, for speeds, sometimes it takes up to 30 seconds to display a directory. I checked the conf file, and the setting for socket options was already included. This has been the issue since I started using samba, and there is one instance of nmbd running, and three of smdb. Thanks again everyone.
Termina
Hey,

Have you tried using more than one Windows machine with this? This may be a silly question, but this IS a LAN, right? You arn't using samba over the internet, are you?

Have you tried (to test speeds) FTP/HTTP from linux to windows, to see if speeds are very low (or if there is a long pause?)

It might be a problem with your network cable/NIC. Also, what version of samba are you using?
Chris-RHS
Yes, this is with multiple windows machines. My ftp speeds from the machine reach 8500kb/s, so there is no issue with the network card. The machine is a dual boot, and runs fast under windows (for sharing docs). I am using Samba version 3.01014.
Termina
You might want to check out /var/log/samba (unless you've set a diffrent log file in smb.conf).

There's obviously a problem, or atleast some tweaking needed. Do you see any errors/warnings there?
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.