Help - Search - Members - Calendar
Full Version: Trouble Automounting Nfs Share
Linuxhelp > Support > Technical Support
SumBudE
I'm having problem getting a nfs share to automount. I can mount it manually with:

sudo mount -t nfs tracy:/share /share

But can't get it to automount on the client. Here are somr relative files from the client:

/etc/auto.master
#
# $Id: auto.master,v 1.3 2003/09/29 08:22:35 raven Exp $
#
# Sample auto.master file
# This is an automounter map and it has the following format
# key [ -mount-options-separated-by-comma ] location
# For details of the format look at autofs(5).
#/misc /etc/auto.misc --timeout=60
#/misc /etc/auto.misc
#/net /etc/auto.net
/~ /etc/auto.direct --timeout=300,rw,intr

/etc/auto.direct
/share -rw 192.168.0.2:/share

And files from the server:

/etc/exports
# /etc/exports: the access control list for filesystems which may be exported
# to NFS clients. See exports(5).

/share 192.168.0.0/255.255.255.0(sync,rw)

Thanks for any help!
Corey
I'm not sure what this /etc/auto.master file is, b ut whenever i setup my system to auto-mount remote nfs mounts, i add something like the following to my /etc/fstab file:

QUOTE
192.168.0.2:/mnt/share /mnt/nfsmount nfs defaults 0 0


You may want to look at some different options other then "defaults" by looking at the fstab manpage.
SumBudE
Adding it to fstab will only mount on start-up. I can do that. What I'm after is to have autofs mount it only when it's accessed since the server isn't always on (home network). If I can get it to automount then it will save me from have to manually mount it each time I need to access the server (I'm lazy). auto.master is consulted by autofs to set up mount points for automounter. That's were I'm having the trouble - with automount.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.