Help - Search - Members - Calendar
Full Version: Suse Compiler?
Linuxhelp > Support > Technical Support
cagey cretin
Heyya,


I installed SuSE on the laptop the other day, and wow! I can mount my USB drive and my wireless nic works (unlike RedHat 9)...

Anyway, I found myself needing to run nmap on a local box, and there is no nmap in Suse, so I download a tarball to compile and lo! there is no compiler!

I've spent the last couple of days trying to install GCC using rpms (suse is pirtported to support them), but when I run `rpm -qa | grep package_name`, it ain't there. I got no error message when I ran rpm -Uvh package_name, but I see no hide nor hair of it. More importantly, I can't run make.

So, how do you install a compiler without a compiler and without the ability to install an rpm? cool.gif

TIA,

cc
cagey cretin
Wow, I found another one...I installed Ubuntu 5.04, and I was able to open USB, set up wireless, but no compiler! mad.gif What's the deal with that?

That's horrible!
cagey cretin
Well yeah...

Weird. I never had the chance to log in as root, nor even create a root password...that is od...

I googled and found a few commands to update Ubuntu for a media player, but part of it helped me get gcc...

sudo get-apt

I have no idea what it is or how it works, and that kinda bothers me, but I guess I'll learn eventually. wink.gif And yeah, I was able to compile nmap from source, which was the whole point of the excercise.

That no "root thing" is weird though...

cc
cagey cretin
...And I found a decent set of documentation for Ubuntu here:

http://www.frankandjacq.com/ubuntuguide/5....5.04/index.html
Corey
Most commercial distributions don't ship with gcc installed by default. With SUSE, you would have to open up YaST and go to the add/remove programs part and do a search for the common development packages. I believe that in suse you can choose different categories fora filter, there should be a Development section with the common packages like gcc, g++, autoconf, automake, m4, etc.

With regards to ubuntu, that probably doesn't come with gcc installed by default either. I have ubuntu installed, but i do a lot of compiling so i don't remember if i had to install that manually or not.

If you would like further explanation on apt-get, i have wrote an in-depth guide on the Linuxhelp Wiki. It could be helpful.
Termina
Ubuntu doesn't let you log in as root for security reasons.

Instead, use sudo (password = your user password)

So 'sudo apt-get install gcc'
cagey cretin
Thanks guys (assumption on my part).

@ Corey: I did try the YaST deal, and only found a gcclib entry but no clue as to how to install gcc. My experience with RedHat was that I could choose to install the compiler during installation, but you had to know where it is at (System Tools).

Thank you for the link to the Wiki (and thank you for taking the time to write it). I'll spend some time in depth there.

@ Termina: Thanks for the sudo hint. Please don't think ill of me, but I had a momentary chuckle thinking about an open-source software that denied root access...Even though I know I was wrong. wink.gif

Joe
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.