Help - Search - Members - Calendar
Full Version: Tried 3 Versions Still No Joy!
Linuxhelp > Support > Technical Support
NI_Sam
Hi,

I'm a newbie to installing Linux, I've used it and Unix occasionally in work but have never installed it before.

Anyway, after spending the time downloading and installing 3 different versions of linux (fedora 3, fedora 4, and Ubuntu) all 64 bit versions and being unable to see so much as a recognisable screen due to what appears to be graphics related problems I'm nearly ready to give the idea up and return permanently to Mr Gates biggrin.gif

My system is as follows (Shuttle XPC SN25P) :

AMD 64 Athlon
PCI Express Nvidia GeForce 6600GT graphics card
NVIDIA nForce 4 chipset
.....

After every install completes (the graphical install wouldn't work for Fedora) I'm met with a completly garbled screen. sad.gif mad.gif

I've tried downloading the following driver from nVidia but the installation produces various errors and many complaints and falls over.

Can anyone help with any suggestions to resolve this?

Thanks in advace,

Sam
Corey
Well, under Ubuntu, you should be able to install the drivers directly from them and not use the one's from nvidia's site. I'm not sure if this is your problem or not.

When you boot into Ubuntu and get to the console, login and do something like:

apt-cache search nvidia

It should bring up a bunch of matches. Check what kernel you're running with:

uname -r

Then install the restricted-modules package that appears in the search, this includes the nvidia driver as far as i know. After this, edit your /etc/X11/xorg.conf file and change in the device section "nv" to "nvidia" then try to start your X server with "startx"

Out of curiosty, what monitor do you have? I've had lots of problems with more recent versions of XFree86 and Xorg on certain monitors i've tried.
homerglemkin
In Ubuntu I had to fix the /etc/X11/xorg.conf file and take out the vertical and horizontal refresh
You should back this up before messing with it. sudo cp /etc/X11/xorg.conf /etc/X11/xorg.conf_backup
Section "Monitor"
Identifier "Generic Monitor"
Option "DPMS"
EndSection

After doing this it worked fine.

For the nvidia driver I followed th unofficial Ubuntu guide
http://ubuntuguide.org/
sudo apt-get install nvidia-glx
sudo apt-get install nvidia-settings
sudo cp /etc/X11/xorg.conf /etc/X11/xorg.conf_backup
sudo nvidia-glx-config enable
sudo gedit /usr/share/applications/NVIDIA-Settings.desktop
and enter the following:
[Desktop Entry]
Name=NVIDIA Settings
Comment=NVIDIA Settings
Exec=nvidia-settings
Icon=
Terminal=false
Type=Application
Categories=Application;System;

The guide works great for new installs.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.