Help - Search - Members - Calendar
Full Version: Rh 9.0 Can Boot From Floppy, But Not From Hd
Linuxhelp > Support > Technical Support
uga.jlg
i have redhat 9.0 as the lone operating system on my computer. its an older HP (800mhz,256 MB, 30GB HD) it can boot from a floppy disk, but i want it to boot from the HD. i had GRUB selected to install during the initial installation, i've tried re-installing it through both the shell and the linux rescue on the install CD, but everytime the computer boots up w/o the floppy i get a "Operating System not found" message in the top left corner. i've ran the linux rescue installing LILO also and installed it from the shell, and i get the same message. i changed the Operating System setting in the BIOS from Win98 to Other, but this had no effect. any help? thank you.

uga.jlg@gmail.com
michaelk
Where are you installing the grub, MBR or the boot partition?

Boot using the install CD and select rescue mode.
Enter the commands:
chroot /mnt/sysimage
grub-install /dev/hda ( replace hda with your actual HDD device)
uga.jlg
thanks for the response. i've tried to install to MBR, but i have tried both. i did what you suggested and and ran linux rescue mode. i got a message saying chroot /mnt/sysimage was entered, so i entered the grub-install /dev/hda line. i then got a line that read: /dev/hda does not have any corresponding BIOS drive.

any more ideas?
michaelk
So post the hardware specs? Are you using regular IDE, SATA, SCSI etc..?
uga.jlg
regular 30GB IDE, 800mhz, 256MB.... i tried grub-install /dev/hdb and grub-install was happy with that, but it didnt fix the problem. the /boot/grub/device.map file looks like:

(fd0) /dev/fd0
(hd0) /dev/hdb
uga.jlg
scratch that, i apologize, i forgot what computer i was working on. its an ATA, here are the specs. its the 30 gig one.
http://perso.wanadoo.fr/rayp/HD/QUANTUM/sp...lct20_specs.htm
michaelk
Can you post your grub.conf file?
uga.jlg
# grub.conf generated by anaconda
#
# Note that you do not have to rerun grub after making changes to this file
# NOTICE: You have a /boot partition. This means that
# all kernel and initrd paths are relative to /boot/, eg.
# root (hd0,0)
# kernel /vmlinuz-version ro root=/dev/hdb2
# initrd /initrd-version.img
#boot=/dev/hdb
default=0
timeout=10
splashimage=(hd0,0)/grub/splash.xpm.gz
title Red Hat Linux (2.4.20-31.9)
root (hd0,0)
kernel /vmlinuz-2.4.20-31.9 ro root=LABEL=/ hdc=ide-scsi
initrd /initrd-2.4.20-31.9.img
title Red Hat Linux (2.4.20-8)
root (hd0,0)
kernel /vmlinuz-2.4.20-8 ro root=LABEL=/ hdc=ide-scsi
initrd /initrd-2.4.20-8.img
uga.jlg
i dont know if this will help...

[root@localhost root]# fdisk -l

Disk /dev/hdb: 30.0 GB, 30020272128 bytes
255 heads, 63 sectors/track, 3649 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

Device Boot Start End Blocks Id System
/dev/hdb1 * 1 13 104391 83 Linux
/dev/hdb2 14 3584 28684057+ 83 Linux
/dev/hdb3 3585 3649 522112+ 82 Linux swap
uga.jlg
alright... after looking over everything i noticed that the HD jumper wasn't in the Master location. it was in the factory default. i changed it and put the install CD in like i was going to reinstall linux altogether, and when i got to the boot loader/partition screen, it wouldnt let me make the hdb2 partition bigger than 2 GBs, so i couldnt have reinstalled if i had wanted to. i put the jumper back in the original spot and it was fine (or back to the previous problem).
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.