Help - Search - Members - Calendar
Full Version: Rh9 Localhost Access
Linuxhelp > Support > Technical Support
cjseyfried
I have a working install of RH9 and have been running Apache Xampp and other server apps, Webmin, etc. I had Verison DSL as my DSL isp and everything worked fine.

I recently switched to Earthlink DSL. Everything works fine, EXCEPT that I Now CAN not access any of my server apps., Apache Xampp, etc. I get a "localhost not found" message.

Even the setup address for the earthlink modem is not reachable - http://172.16.0.254/setup.html

I can not firgure out any reason, everything else is the same ? Earthlink does not support Linux so I can not get assistance from them.

Can anyone Help ?

Curtis Seyfried
DS2K3
Just add the line "127.0.0.1 localhost" to /etc/hosts (without the quotes). If it's already there, of if it still doesnt work, then maybe something else is wrong, but that should do the trick.

D
cjseyfried
Thank you for your advice. This line was already there. I deleted it and re-entered it and saved the file. This changed nothing. I even went into hosts.allow and added the same line, no change.

When I try to lets say access Webmin http://localhost:10000/ I get a "resolving localhost" in the status bar at the bottom of my browser, then a "connwcting to localhost," but nothing else and it just hangs there.

The same thing if I try to access Apache Xampp, http://localhost:8080
michaelk
Can you ping 127.0.0.1 and localhost?
Are you sure all of the servers are still running?
Does ifconfig show a valid lo and IP address?
cjseyfried
pinging 127.0.0.1 works fine.

pinging localhost gives no results

ifconfig shows eth0 and ppp0 exist with a bunch of stats for each.
DS2K3
Can you conect to 127.0.0.1:10000 or http://127.0.0.1 ?
cjseyfried
No, I tried that after seeing that it could be pinged. This is very strange, I have never had this happen. It all started when I configured EarthLink DSL, everything else works fine.

The only changes were the switch from Verizon to Earthlink, which is when this started, then I switched modems, with no changes. I can't see how a different DSL ISP could affect my localhost.
DS2K3
Try running "netstat -ltp" to see whether the services are actually running, and which interfaces they are running on.

D
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.