Help - Search - Members - Calendar
Full Version: Problems Configuring Nforce Sound Driver - Suse
Linuxhelp > Support > Hardware Support
antiNeo
I recently installed SUSE 9.1 Personal onto my shuttle computer witch uses the nForce2 chipset. In order for my network and sound to work, I installed the nForce driver as instructed by nVidia. After the installation, I continued to configure the network driver as instructed by nVidia, and it worked. However, once I continued reading the instructions on how to configure the sound driver, I stumbled upon this line:

"Following the instructions to edit the configuration file /etc/modprobe.d/sound."

The problem is that I don't have a file named 'sound' under modprobe.d.

Any help would be appritiated, as this is my first linux system.
DS2K3
I would imagine that you need to make a file called "sound" and then follow the instructions from there.

D
antiNeo
Okay, I created a text file named 'sound' and added this line as in the instructions:

alias sound-slot-0 nvsound

I then restarted, but there was still no sound. It seems to have recognised the file, though, because there is now a backup file named 'sound-' in the same folder.

Thank you for the quick reply.
antiNeo
Also, after I added the sound file, when I look at YaST it shows a new 'null' sound card that wasn't there before. The 'null' card has no options and says 'not running' as it's state.

I also should have mentioned earlier that when trying to add a sound card by using YaST it gives me the error: "The kernel module snd-intel8x0 for sound support could not be loaded. This can be caused by incorrect module parameters, including invalid IO or IRQ parameters."

How confusing my first experience with linux is becoming! If it takes me half the time to learn linux as it took me to learn MS-DOS, I could never figure this out! sad.gif
Corey
I have an nForce1 motherboard, and I must say, don't even bother with using nvaudio and nvnet. These were a pain in the butt to setup, and not really good quality to use. I would suggest you use drivers that come with your kernel, i'm not 100% sure, but i think you can get different free drivers for nvaudio and nvnet. For my board it was the snd-intel8x0 alsa driver and 8139too ethernet driver. May be different with nforce2, but have a look around, i'm sur eit's metioned somewhere.
antiNeo
biggrin.gif Yay, another driver to try!

[Opens google and finds ALSA driver.]

blink.gif Wow, that's a lot of instructions for a linux newbie to follow. Besides, I am almost 100% sure that is the same driver I saw in YaST. The place I am looking at is here.

If I am ever to install this driver, I'm going to need a little more help. Man, I hate asking for so much help... I feel like such a n00b. sad.gif
Corey
But, you are a noob smile.gif That's alright, we like noobs.

So, you already tried the intel8x0 driver? Yes, that would most likely be the one that's in YaST. I'm pretty sure that is the right driver, but, just to be safe, can you give us the motherboard that you're using? It would help a lot so I can look it up, different nforce boards use different underlying chipsets.
antiNeo
I have a Shuttle SN41G2V3 which uses a FN41 mobo. Also remember the error that YaST gave me: "The kernel module snd-intel8x0 for sound support could not be loaded. This can be caused by incorrect module parameters, including invalid IO or IRQ parameters." What does that mean?
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.