I'm trying to do serial communications between two PCs, but probably the settings of my port are wrong, because several communication programs (lrzsz, g-kermit, minicom) do not work properly, I'm not able to send files. The settings are:
@:~ $ stty -F /dev/ttyS0 -a
speed 9600 baud; rows 0; columns 0; line = 0;
intr = ^C; quit = ^; erase = ^?; kill = ^U; eof = ^D; eol = <undef>; eol2 = <undef>; start = ^Q; stop = ^S; susp = ^Z;
rprnt = ^R; werase = ^W; lnext = ^V; flush = ^O; min = 1; time = 0;
-parenb -parodd cs8 hupcl -cstopb cread clocal -crtscts
-ignbrk -brkint -ignpar -parmrk -inpck -istrip -inlcr -igncr -icrnl ixon -ixoff -iuclc -ixany -imaxbel
-opost -olcuc -ocrnl -onlcr -onocr -onlret -ofill -ofdel nl0 cr0 tab0 bs0 vt0 ff0
-isig -icanon -iexten -echo -echoe -echok -echonl -noflsh -xcase -tostop -echoprt -echoctl -echoke
@:~ $ setserial /dev/ttyS0 -a
/dev/ttyS0, Line 0, UART: 16550A, Port: 0x03f8, IRQ: 4
Baud_base: 115200, close_delay: 5000, divisor: 0
closing_wait: 37856
Flags: spd_normal skip_test

I tried changing something, like crtscts and ixon, but nothing changed. I tried that on Ubuntu Linux 4.10, Mandrake Linux (10?) and Slackware Linux (9?). Thanks for your help.