Hi,

I've got a RAID5 raidzone from consensys that has a corrupted files system. It's file system is xfs. When I run xfs_repair it gets through the first 5 stages, sometimes giving out errors but making it through. Eventually it tries to move disconnected inodes to lost+found. It does this for a while and then produces the following error:

xfs_repair: buf calloc failed (4132 bytes): Cannot allocate memory

Since it was a memory error I tried rerunning xfs_repair again and again. It kept getting farther and farther along, ie the inodes it was moving had higher and higher numbers. However, now it doesn't go any farther. It tries to move the same inodes to lost+found over and over again, no matter how often I run xfs_repair, and fails in the same spot. If I run xfs_repair -n it gets past that spot and continues on letting me know that it would have moved inodes and reset inodes.

Does anyone know of a way to maybe skip a portion of the inodes to be fixed, or maybe another way, besides running xfs_repair to fix a corrupted file system? Thanks so much.


-NifflerX