Help - Search - Members - Calendar
Full Version: Sharing Headache With Smb4k
Linuxhelp > Support > Technical Support
connely
I'm trying to share a local filesystem with samba using smb4k as a gui. /dev/hda1, which is a windows98 disk, is mounted in /mnt/windows. I can read/write with no problem.
So I open webmin to set this drive up as a share under servers/samba. This happens without incident. It shows up in my list of shares as the name I gave it, win98. The path is correct.
Here's where the problem comes in. When I open SMB4K I can see win98 in the share list. However, when I double click to mount the share I get this error message:

(random numbers):tree connect failed:ERRDOS - ERRnosuchshare (you specified an invalid share name)
SMB connection failed.

I have given this share a multitude of names which all give me this same error message. The strange thing is that every once in a while it will mount and I can browse it on my other machine. It makes no sense to me. Everything is configured exactly the same way as my other machine. However, my other machine instantly sees the local NTFS drives and mounts the shares I set up for them without a problem. Is this a FAT thing?

Please help before I break another keyboard over my knee mad.gif
Thanks in advance.
My previous post on a similar problem.
Robert83
Hello,

could you show me how does the [global] section , and the specific [share] section (which gives you the error) looks like in your samba config file , usualy located at /etc/samba/smb.conf .

The thing is , error might happen sometimes when using a 3rd party config utility to configure samba.

(with rh9 smile.gif , I had a similiar problem configuring squid via webmin).

Sincerely
Robert B
connely
You'll have to excuse me, but I'm a little unsure as to what you are asking for huh.gif
I'm still a linux noob so please bear with me.

I think I may have found the problem but I have no idea how to fix it. I noticed that I am only getting this error message if my other mandrake linux machine is on.

This is briefly my setup:
comp A: WinXP on partition 1. Mandrake on partition 2
comp B: Win98 on partition 1. Mandrake on partition 2
The local windows filesystems on each machine are mounted and I can browse them.

If I have XP on comp A and linux on comp B the win98 share mounts perfectly and I can browse it from comp A. However if I am running linux on comp A and linux on comp B I get the error message and the share will not mount. But the XP share on comp A will mount and I can browse it from comp B while both are running linux ohmy.gif Get it?

Any ideas what this could be? Remember to speak noob to me biggrin.gif

EDIT: In my other post DS2K3 told me I needed to setup a samba hostname and workgroup which I haven't done because I didn't know how. Could this be the problem? And could I get some help doing that?
Robert83
Hi,

you remember norton commander from the good old days ?

please install midnight commander (mc for short)

and this config file smb.conf located in

/etc/samba

1. backup : copy smb.conf to /backup/smb.conf (you can create the /backup dir with f7 using midnight commander.
2. type in the following command (to the console) : /etc/init.d/smb stop
(which will return to you that it has stopped smbd and nmbd [ok] for both , ...if it returned [failed] don't worry that means it already stopped)
3. open up th /etc/samba/smb.conf file and delete everything in it.
4. type in the following code , just to see if this will work for you without any problems...

CODE
[global]
       workgroup = ms_group  # use whatever workgroup you used with the rest , use UPPERCASE...
       netbios name = file-server
       server string = Samba %v
       log file = /var/log/samba/%m.log
       max log size = 0
       prefered master = Yes
       local master = Yes
       os level = 65
       domain master = Yes
       wins support = Yes
       time server = Yes
       security = share
       interfaces = eth0,lo
       bind interfaces only = Yes
       name resolve order = wins bcast hosts
       smb ports = 139 445

[IPC$]
      path = /tmp
      hosts allow = 192.168.1.0/24, 127.0.0.1   # first is the subnet you are using , second
                                                              # the loopback interface
      hosts deny = 0.0.0.0/0

[win98-1]
      comment = Windows 98 share (c)
      path = /mnt/win98/c # change this to where your win98 (c) is mounted
      writeable = yes
      create mask = 0777
      directory mode = 0777
     
[win98-2]
      comment = Windows 98 share (d)
      path = /mnt/win98/d
      writeable = yes
      create mask = 0777
      directory mode = 0777


the above example will make samba the master browser ,wins and the time server for this workgroup.
if you don't want that change the following in global
[global]
prefered master = no
local master = no
remove os level = 65 line
domain master = no
wins support = no
time server = no

see what happens now ?

don't forget to modify the path for the shares [win98-1] and [win98-2].

5. /etc/init.d/smb start

please wait 1 minute approx...then try to browse for the above shares...

Sincerely
Robert B
connely
Thanks for the help so far, Robert83.

I tried installing MC but I get an error saying:
error:no acceptable C compiler found in $PATH

I have glib installed so I have no idea why this message is coming up.

It looks like you wanted me to install MC just to make the backup copy of smb.conf. So to avoid another headache I skipped installing MC and made a backup folder as root and made a copy of smb.conf and put it there.

So I followed the rest of your instructions to no avail. I changed the workgroup and path to the win98 drive. The new share name shows up, but as soon as I try and mount the share the authentication box pops up asking for user and password. I put in the user and password of the owner (root) and hit okay, then the box pops up again asking for the user/password. It gets caught in this loop and won't mount the share.

Am I not just telling samba "here is the filesystem, share it here"? Why is this such a hassle?
connely
EDIT: Thought I had something there for a second. I restored the smb.conf file to the original then renamed the win98 share to win98_1. It mounted the share without any problems. I restarted the computer, tried to remount, and got the same error message mad.gif

Problems like this almost make me forget how much I hate winbloze. The simplist tasks are often the hardest.
DS2K3
glibc is a C Library, not a C Compiler. You need to install GCC (the GNU Compiler Collection) to be able to compile tihngs.

D
connely
QUOTE
ou need to install GCC (the GNU Compiler Collection) to be able to compile tihngs.


Okay. Just installed GCC. Went to install MC and I got an error message telling me I need glib 1.2.6 or above. I have 2.3.3 installed.

I'd rather not screw around with anything else unless I absolutely need to. I'd rather avoid any other problems until I get this sharing issue solved.

Thanks for the info smile.gif
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.