Help - Search - Members - Calendar
Full Version: Understanding Ftp
Linuxhelp > Support > Technical Support
CanMike
This is my world: RedHat Enterprise Linux V4

I really having trouble getting my FTP applications to work.

I started by checking to see what FTP app I'm running:

According to 'Red Hat Linux Bible' I issued, as root:

# rpm -qa wu-ftpd --> nothing returned
# rpm -qa vsftpd --> nothing returned

So I guess that means I'm not going to be able to use those apps.

Yet, when I issued the command:

FTP it returns the prompt '>', which is a FTP waiting for a command.

The name of my machine in 'mlinux' and when I issue the command:

ftp mlinux --> it returns
fpt: connect: Connection refused

So I'm running something, right?

Does anybody have any ideas about how I go about tracking down:

1: Which FTP App is running on my box.
2: How do I get it up and running.

Right now to transport SQL's (that deal with file systems), between my Windows XP Pro box and my Linux box I burn a CD. Ready stupid when I have WS-FTP running on my window box just waiting to transfer files.

Any advise would be appreciated.

Mike Parish, Toronto Canada
Robert83
Hi,

you will first need to install a ftp server, a good one would be vsftpd

using up2date install it

the name of it is vsftpd

once done

go and edit vsftpd.conf as you need

the following would be important if you would like local users to access the computer via ftp

local_enable=YES (but for me in CentOS 4.0 , it is so by default)

so all you need to do is

/etc/init.d/vsftpd start
chkconfig vsftpd on

adduser testftp
passwd testftp

and then from windows, or other linux comp ftp in , type username testftp
password testftp

aditional configuration might be necesary, but everything is explained in config file, see for yourself (not hard)

also
/etc/vsftpd.ftpusers
/etc/vsftpd.user_list

might be important, since with these two files you allow or disable users from logging in.

NEVER EVER ALLOW ROOT TO LOGIN VIA FTP amen

Sincerely
Robert B
CanMike
Thank-you for your help. But..

I own RedHat Enterprise Linux WS version 4. Note the 'WS' which stands for 'Work Station'. According to Red Hat vsftpd is not part of the O/S, nor is it supported if you download a version from the internet.

I called them and there is a work around though, start the openssh-server application on my linux box and download and install WinSCP on my Window box.

For all 3 of you out there using RH Enterprise WS v4, here's how to set it up:

On Linux: Logon as 'root'

Check to see if open-server is installed:

# rpm -q openssh-server
on my O/S it returned:
openssh-server-3.9pl-8.RHEL4.1 Yippee!!!

Next start the damn thing. ( I apologise if anyone is offended, but I've been dealing with this problem for a few days and I'm slightly upset with Red Hat right now)

service sshd start ---> note the 'd' at the end

on my O/S it returns:
Starting sshd: ( OK )


Done

On my Window XP Pro, I downloaded freeware WinSCP, installed and away I went.

Again, thanks for your help and maybe I'll download vsftpd one day install it just to wage my nose at Red Hat. This is working well and I can send my SQL's from one machine to the next.
DS2K3
There is a diffrence between "not supported" and "wont work". They just mean that they wont help you fix it if it goes wrong. Downloading an RPM should suffice, and failing that you could compile it yourself.

D
CanMike
I agree. It will probably work fine, but I've got work to do and sshd allows me to transfer files.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.