Help - Search - Members - Calendar
Full Version: Hard Drive Doesn't Like To Share
Linuxhelp > Support > Technical Support
connely
Hi,

I am trying to set up smb4k to share a local FAT drive. It is a 20GB drive which holds my win98 partition (hda1). Mandrake 10.1 is installed on a second 6GB HDD (hdb1). And I am trying to view this win98 drive on another machine (XP) over my network.

I can mount my windows drive. I have full access to it and have no problems reading/writing/executing. I also have no problems viewing shared samba mounts on my XP machine. I can also view shared folders from the XP machine.

When I try sharing win98 on hda1 (right click>share) from /mnt I get a message saying only directories in the home directory can be shared. So I mounted the windows drive into one of my usernames in home. When I right click to set the sharing I am able to set it to shared. However it will not show up in smb4k!?

All of my other shares are set up exactly the same way. Does the fact that it's a physical drive make a difference?

BTW: I have read elsewhere that I may need to set up ip tunneling since I am going through a router. I will deal with that later once I find how to see this in smb4k.

Edited to add:
Just in case this is needed.....
QUOTE
/dev/hda1 /home/admin/win98 vfat umask=0,iocharset=iso8859-1,codepage=850 0 0
DS2K3
You might not be sharing it as a Windows share (which is what smb4k looks for).

If not, install webmin (www.webmin.com - but ships with MDK [use the package manager]) and use that to add samba shares (it's pretty easy to use).

D
connely
Thanks for the reply, DS2K3.

I installed webmin. When I try mounting the drive as a samba share I keep getting errors like "share name cannot be used", or "device is already mounted".

How exactly do I mount this in webmin? Do I need to have the drive mounted elsewhere first?

Better yet, I would like to learn how to do this from command line. Maybe my original mount method isn't setting it up for a samba share. I'm pretty new to linux so I wouldn't doubt if I am messing this up from the start smile.gif

This is how I am mouting the drive (admin is a user):
mount /dev/hda1 home/admin/win98 -o uid=admin

What can I add/subtract to mount this as a samba share?

Thanks
DS2K3
try (as root): mount -t vfat /dev/hda1 /place/to/mount

To get root access from a command line, type "su -" followed by your root password.

You dont mount as a samba share, you mount as a FAT disk volume, and then export it as samba. Also, are you sure the drive is /dev/hda1 ?

Mounting makes a disk available to your computer, exporting it makes it available over a network.

I'm not sure how you add samba shares from the command-line, or even where the config file is. I have only ever used Webmin to do it. NFS I can do with my eyes closed, but since Samba usually "just works" I have never felt the need to question it...

D
connely
I just noticed something. Smb4k just popped up with:
Network-ADMIN_WIN98
Type-Disk
comment-home/admin/win98

However when I double-click to mount it I get an error:
7347:tree connect failed: ERRDOS - ERRnosuchshare (you specified an invalid share name)
SMB connection failed.

I can browse the drive so I know it's there.

I get this exact message when I try going through webmin. There is a bunch on google with this error message, but it seems to be instance specific. So I'm having a tough time finding anything specific on this.

Any ideas? I wouldn't think this would be such a headache. Seems to me like this should be a simple task.
DS2K3
Why do you want to mount the volume on the same computer you are sharing it from? Or have I missed something?

D
connely
QUOTE
Why do you want to mount the volume on the same computer you are sharing it from?


From what I understand I need to mount it in order to share it. In order to share it I need to mount it within the home folder otherwise I get no option to share (non-home folders/files give a message saying files must be in home folder to share. There is no option to share). If I could share it right out of /dev I would. That would make this headache go away. But alas the option to share is only out of my /home folder.

Unless you know of another way..........?
DS2K3
Things in /dev are raw devices, not filesystems. You need to mount the device as a filesystem using mount. To do that, type "mount -t vfat /dev/hda1 /mnt/windows". Once you have mounted the drive in /mnt/windows, you can access it locally. To make it avialble to computers over the network, you need to share it. Because the Mandrake sharing tools are kind of useless for most people, use Webmin to add the share (under servers -> samba). You will also need to setup the samba hostname and workgroup, but it's pretty self explanatory.

D
connely
Ah ha! Got it!

In webmin I was attempting to mount a windows networking filesystem under system/disk and network filesystems/add smbfs. When I first installed webmin I went through the servers section and must have missed the samba section. Went through it and had the drive up and shared in minutes.

Thank you very much for your help biggrin.gif
DS2K3
No Problem

*Resolved so Closing*

D
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.