Apparently my modem terminates the connection right after it is established. Anyone know why?

Apr 26 00:25:22 localhost pppd[4251]: pppd 2.4.2 started by root, uid 0
Apr 26 00:25:23 localhost chat[4252]: abort on (BUSY)
Apr 26 00:25:23 localhost chat[4252]: abort on (NO CARRIER)
Apr 26 00:25:23 localhost chat[4252]: abort on (VOICE)
Apr 26 00:25:23 localhost chat[4252]: abort on (NO DIALTONE)
Apr 26 00:25:23 localhost chat[4252]: abort on (NO DIAL TONE)
Apr 26 00:25:23 localhost chat[4252]: abort on (NO ANSWER)
Apr 26 00:25:23 localhost chat[4252]: abort on (DELAYED)
Apr 26 00:25:23 localhost chat[4252]: send (ATZ^M)
Apr 26 00:25:23 localhost chat[4252]: expect (OK)
Apr 26 00:25:23 localhost chat[4252]: ATZ^M^M
Apr 26 00:25:23 localhost chat[4252]: OK
Apr 26 00:25:23 localhost chat[4252]: -- got it
Apr 26 00:25:23 localhost chat[4252]: send (ATDT5283658^M)
Apr 26 00:25:23 localhost chat[4252]: expect (CONNECT)
Apr 26 00:25:23 localhost chat[4252]: ^M
Apr 26 00:25:46 localhost chat[4252]: ATDT5283658^M^M
Apr 26 00:25:46 localhost chat[4252]: CONNECT
Apr 26 00:25:46 localhost chat[4252]: -- got it
Apr 26 00:25:46 localhost chat[4252]: send (d)
Apr 26 00:25:47 localhost pppd[4251]: Serial connection established.
Apr 26 00:25:47 localhost pppd[4251]: Using interface ppp0
Apr 26 00:25:47 localhost pppd[4251]: Connect: ppp0 <--> /dev/ttyS0
Apr 26 00:25:48 localhost pppd[4251]: Connection terminated.
Apr 26 00:25:49 localhost pppd[4251]: Hangup (SIGHUP)
Apr 26 00:25:49 localhost pppd[4251]: Exit.