Help - Search - Members - Calendar
Full Version: Mandrake 10.1 And My Sata Drive
Linuxhelp > Support > Hardware Support
Greetings all,

After one final crash with Windows, I've finally gathered up my courage and I'm trying Linux. I have 3 HD on my system (ASUS A78NX Deluxe, AMD 3200), 2 IDE drives, one with Windows XP on it and the other now with Mandrake 10.1. The 3rd drive is 180 Gb SATA drive that has a partition but is currently unformatted.

The problem is that when I first tried to install Mandrake, it got stuck during the installation of the SATA/RAID driver (SIS 3112). More specifically, it got stuck trying to unload IRQ 11. This is not my first attempt to do this. I tried the same thing before with Fedora, with the same result. The system just hangs with the message "unloading IRQ 11" on the screen.

I disconnected the drive and retried the installation and everything worked out perfectly. Mandrake installed without a hitch. After I turned off the pc, I re-connected the SATA drive and re-started and Mandrake locked-up again. In the verbose mode, it was trying to unload IRQ 5 this time.

Nothing is wrong with the drive, it used to contain Windows XP and worked perfectly well. I am missing some obscure BIOS setting? Is there anything else I should do before?

Keep in mind that I'm really new at this when you reply. Don't use scary words please.

SATA support is unfinished I think... Or possibly just not available on Mandrake/Fedora kernels (the kernel is the bit that handles most of the basic functions of the computer like RAM and "talking" to devices). Not sure how you could work around - But I dont have a SATA drive, so I have no experience.

Just to clarify a little bit; although I'm new to Linux, I have done some research beforehand. Mandrake is capable of supporting SATA drives. The problem occurs when it is trying to load the incorporated SATA driver. It seems to want to "unload" an IRQ and this is where it hangs. Do I have to change something in my BIOS?
The SATA implementation, whcile usable in many situations, isnt perfect yet. It's possible that ewither your BIOS of drive are using features not yet supported. You might like to fiddle with the PnP settings in the BIOS, since they will influence whteher it is the BIOS or Linux that allocates IRQs to devices.

This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2018 Invision Power Services, Inc.