Help - Search - Members - Calendar
Full Version: Installing Linux On Compaq 5050
Linuxhelp > Support > Technical Support
Hi, I am new to Linux. I have heard about it with much curiosity for years, and thus decided to buy the book Linux for Dummies, which included a DVD with Debian, Fedora Core 3, Knoppix liveCD, SuSE liveCD, and Xandros.

I have a computer with a horrible problem called Windows98, and was hoping that Debian or Fedora could solve this problem.

The computer is a Compaq Presario 5050, and the delimma is that it seems impossible to boot from the CD drive. In the instruction manual on the Debian CD's I burned from the images on the Dummies DVD, there is a vague mention of some method for installing Debian without booting from the CD drive....
Even if your system doesn't support booting from a CD-ROM, you can use the CD-ROM in conjunction with the other techniques to install your system, once you've booted up by other means...

How do I do this? The CD I have is
Debian GNU/Linux 3.0 r2 "Woody" - Official i386 Binary-1 CD
, and I also have a second CD.

Also, I have no drive partitioning software besides fdisk, but I figure this should not be a problem because I want to get rid of the existing Windows 98 system completely.

Thank you verily,

P.S. In addition, DOS does not seem to recognize the CD-ROM drive as existing at all.
Humm, check and make sure that your CD-ROM comes before you hard-drive in your bios congifuration. Thats the first step. Usually it does, but on older machines sometime they didn't to speed up the boot processes. If you put the CD-ROM first in your boot order it should boot up.

If that doesn't work, let us know and I can step you through how to create a floppy that will get your going. Asume it has a floppy drive.

Lastly, you shouldn't have any problem with not having any partition software, the installed will have what you need. Just trash the fat32 partition and let linux have its way with your hd. Good luck.
I don't know how to change the BIOS configuration. On my laptop, I press escape as the Compaq logo shows up, then down-arrow to the CD drive and press Enter to boot from it. However, my Presario 5050 seems immune to all button-pushing during startup. I checked Windows help (this was the first time I had ever resorted to Windows Help, by the way), and found out about Startup Discs; apparently this computer boots from the floppy drive if it detects the right files on a floppy - otherwise it tells you to remove the floppy, then happily continues starting up Windows.

So, please explain the floppy thing.

Thank you soooo much,
YAY! I tried pressing random keys on the keyboard while it was starting up. I had done this before, but this time it worked. The key to boot from CD is either Delete or Enter, I think.... Anyway I don't need help anymore. tongue.gif

laugh.gif laugh.gif Thanks a bunch for being here,

P.S. Yay, Linux!
I now find that I cannot use my PC's modem with Linux. Since I need the internet to get software packages that I probably need, I tried using a USB-based modem, but found that I don't know how to do this with Linux.

Also, it seems that I can't shut down the computer from the Gnome GUI, but have to use the command prompt.


P.S. Yay Linux!
USB modems tend to be more difficult to get working. What model is your built in modem?

(Can run "dmesg" and post the output here?)

Okay. Here is dmesg.

daniel@DeepThought:~$ dmesg
Linux version 2.2.20-idepci (herbert@gondolin) (gcc version #1 Sat Apr 20 12:45:19 EST 2002
BIOS-provided physical RAM map:
BIOS-e820: 0009f000 @ 00000000 (usable)
BIOS-e820: 05f00000 @ 00100000 (usable)
Detected 334096 kHz processor.
Console: colour VGA+ 80x25
Calibrating delay loop... 666.82 BogoMIPS
Memory: 95432k/98304k available (1164k kernel code, 412k reserved, 1224k data, 72k init)
Dentry hash table entries: 16384 (order 5, 128k)
Buffer cache hash table entries: 131072 (order 7, 512k)
Page cache hash table entries: 32768 (order 5, 128k)
Intel machine check architecture supported.
Intel machine check reporting enabled on CPU#0.
128K L2 cache (4 way)
CPU: L2 Cache: 128K
CPU: Intel Celeron (Mendocino) stepping 00
Checking 386/387 coupling... OK, FPU using exception 16 error reporting.
Checking 'hlt' instruction... OK.
Checking for popad bug... OK.
POSIX conformance testing by UNIFIX
mtrr: v1.35a (19990819) Richard Gooch (
PCI: PCI BIOS revision 2.10 entry at 0xfa104
PCI: Using configuration type 1
PCI: Probing PCI hardware
Linux NET4.0 for Linux 2.2
Based upon Swansea University Computer Society NET3.039
NET4: Unix domain sockets 1.0 for Linux NET4.0.
NET4: Linux TCP/IP 1.0 for NET4.0
IP Protocols: ICMP, UDP, TCP
TCP: Hash tables configured (ehash 131072 bhash 65536)
Starting kswapd v 1.5
vga16fb: initializing
vga16fb: mapped to 0xc00a0000
Console: switching to colour frame buffer device 80x30
fb0: VGA16 VGA frame buffer device
Serial driver version 4.27 with HUB-6 MANY_PORTS MULTIPORT SHARE_IRQ enabled
ttyS00 at 0x03f8 (irq = 4) is a 16550A
pty: 256 Unix98 ptys configured
RAM disk driver initialized: 16 RAM disks of 4096K size
loop: registered device at major 7
PIIX4: IDE controller on PCI bus 00 dev a1
PIIX4: not 100% native mode: will probe irqs later
ide0: BM-DMA at 0x2020-0x2027, BIOS settings: hda:DMA, hdb:pio
ide1: BM-DMA at 0x2028-0x202f, BIOS settings: hdc:DMA, hdd:pio
hda: ST38641A, ATA DISK drive
hdc: LTN301, ATAPI CDROM drive
ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
ide1 at 0x170-0x177,0x376 on irq 15
hda: ST38641A, 8063MB w/128kB Cache, CHS=1092/240/63
hdc: ATAPI 32X CD-ROM drive, 120kB Cache
Uniform CD-ROM driver Revision: 3.11
Floppy drive(s): fd0 is 1.44M
FDC 0 is a post-1991 82077
3c59x.c 18Feb01 Donald Becker and others
pcnet32.c: PCI bios is present, checking for devices...
via-rhine.c:v1.08b-LK1.0.1 12/14/2000 Written by Donald Becker
Partition check:
hda: [PTBL] [1027/255/63] hda1 hda2 < hda5 >
apm: BIOS version 1.2 Flags 0x03 (Driver version 1.13)
apm: disabled on user request.
VFS: Mounted root (ext2 filesystem) readonly.
Freeing unused kernel memory: 72k freed
Adding Swap: 337324k swap-space (priority -1)
CSLIP: code copyright 1989 Regents of the University of California
PPP: version 2.3.7 (demand dialling)
PPP line discipline registered.
PPP BSD Compression module registered
SLIP: version 0.8.4-NET3.019-NEWTTY-MODULAR (dynamic channels, max=256).
SLIP linefill/keepalive option.

About my desktop's modem:
The modem I am using is not the computer's original modem; the first one stopped working. The old Windows system called this modem "Boca PCI Modem Controller", "Boca Winstorm 56K VoiceModem". The "Boca Research" website did not have Linux drivers. The CD that I have labeled "Modem Driver for re-installation" does not have a driver on it. The Windows driver from "Boca Research" is called m56hi.

About my USB modem:
The USB modem I was trying claims to be Linux compatible. The modem is "SupraMax 56K USB V.92 MODEM". When I plug the modem into my Windows laptop's USB port, the "POWER" light on it lights up. However, this does not occur with my desktop computer. I have never tried any USB devices with my Desktop computer before, not even when it was a Windows computer.

Thank you.

1. I continue to shut down my computer by typing 'halt' in the command window. Is this OK?
2. In addition, the text file I used to paste my dmesg info seems to have changed between my Linux desktop and my Windows laptop; I believe a line that said 'Dummy' has disappeared, as well as a couple of lines complaining about ISDN-something and telling me to run some configuration program. All other changes (line breaks, formatting...) returned to normal when I pasted the file from Notepad to this text box.
Or perhaps my dmesg has simply changed between last night's startup and this morning's?...
Typing halt is fine

I cant see anything about the modem in dmesg (i'll have another look in a minute) so perhaps it isnt being deteced at all.

Formatting problems are due to differences betwwen Windows and Linux. Windows use rn as the end-of-line-character, whereas Linux uses just n (and MacOS just uses r).

If the light doesnt come on when you plug the USB modem in, then the USB drive might be disabled - either by the BIOS, or because you dont have the required modules in the kernel. (What does "lsmod" output?)

Also, try running "tail -f /var/log/messages" and then plugging in the USB modem - It it detects it I would expect to see some kind of message appearing in the system logs, and maybe some indiaction as to why it wont work...

nls_cp437 3896 1 (autoclean)
slip 7252 2 (autoclean)
dummy 964 0 (unused)
bsd_comp 3688 0 (unused)
ppp 20300 0 [bsd_comp]
slch 4336 1 [slip ppp]
af_packet 6136 1

"tail -f /var/log/messages":
DeppThought:~# tail -f /var/log/messages
Apr 9 06:44:27 DeepThought kernel: PPP line discipline registered.
Apr 9 06:44:27 DeepThought kernel: PPP BSD Compression module registered
Apr 9 06:44:30 DeepThought lpd[208]:restarted
Apr 9 06:44:30 DeepThought kernel: SLIP: version 0.8.4-NET3.019-NEWTTY-MODULAR (dynamic channels, max=256).
Apr 9 06:44:30 DeepThought kernel: SLIP linefill/keepalive option.
Apr 9 06:44:30 DeepThought diald[177]: start s10: SIOCSIFMETRIC: Operation not supported
Apr 9 06:44:32 DeepThought xfs: ignoring font path element /usr/lib/X11/fornts/cyrillic/ (unreadable)
Apr 9 06:44:33 DeepThought xfs: ignoring font path element /usr/lib/X11/fonts/CID (unreadable)
Apr 9 06:51:53 DeepThought syslogd 1.4.1#10: restart.
Apr 9 07:04:26 DeepThought -- MARK --

Doesn't really look hopeful, does it? (Not that I know what I'm talking about.) I'll probably just get another modem unless you have some suggestion.

SupraMax 56K USB Model SUP2890, Lucent Pegasus chipset (USBVID_045A&PID_0B4A) - - USB
? ? CNH56D-USB
SupraMax 56K USB Model SUP2920, Rockwell HCF chipset (USBVID_045A&PID_0B68&MI_00)

which says
2890 chip=good
2920 chip=bad

boca - = ? = unok


new modem time- confirmed-

- and - dont buy a winmodem , another winmodem.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2018 Invision Power Services, Inc.