Help - Search - Members - Calendar
Full Version: Cloning Problems: Systemimager ?
Linuxhelp > Support > Technical Support
dereko
Hi,

Iíve gone through the process of cloning a machine before with no problems but for some reason I canít get it to work again.

Machine to be cloned/golden client, (Works as it should)

Partitions: IDE1 starndard 80gig hardrive
Hda1 linux Ė FILE SYSTEM TYPE: reiserfs
Hda5 linux swap

Distribution: Debian Sarge
Boot loader: Grub v0.95
Kernel: 2.6.8-2-i386

Systemimager version 3.4.0

My cloning process, dhcp is set up on a internal network.

On golden client:
# prepareclient Ėserver 192.168.1.6

On the image server:
# si_getimage -golden-client 192.168.1.37 -image kioskv3.0 -updates-script YES
# si_addclients -host node -domainname example.com -host-range 1-10 -script kioskv3.0 -ip-range 192.168.1.201-192.168.1.210 2>/dev/null
# si_addclients -host node -domainname example.com -host-range 1-10 -script kioskv3.0 -ip-range 192.168.1.201-192.168.1.210

I then created a boot floppy for a new machine identical in hardware on the golden client.

I put in the boot floppy and the cloning process completes successfully.

But when I reboot the machine it stops at

Loading DMI pool dataÖ or something like that it says

Loaded the machine from live-cd and ran the following commands

Anyhow I tried to fix this by booting clone machine 1 from knoppix live-cd

[shell]
root@0[dev]# mount -t reiserfs -o rw /dev/hda1 /mnt/hda1
root@0[dev]# grub-install --recheck --root-directory=/mnt/hda1 /dev/hda
Probing devices to guess BIOS drives. This may take a long time.

[/shell]

took out cd and rebooted. got passed the grub loader properly this time and started loading
up debian but early on it got this error message

/sbin/init: 426: cannot create /dev/null : Read-only file system
/sbin/init: 427: cannot open dev/console : no such file
Kernel panic: Attempted to kill init

can anyone spot anything Iím doing wrong here?

I cloned a machine using the above process which worked perfectly.. the only difference being it was a ext3 filesystem instead of reiserfs.. ideally Iíd like to keep reiserfs if possible.

I have 20 machines to clone.. and if I donít sort this soon Iíll have to install each one of them individually which will take a long time since there is allot of special configuration.

Can anyone shed any light on this?

Anything at all even give me other suggestions how I might do this.

Thanks,
Derek
DS2K3
Looks like the /dev/ filesystem isnt correctly configured. The "Loading DMI Pool Data..." is just a BIOS messsage while it scans the Floppy-Drive for botable media.

I dont have any experience with a) cloning machines, or b ) debian, though

D
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.