I'm pretty new to linux, I tried it out using knoppix live-cd on my laptop (Acer aspire 1353XC), which worked fine (except for sometimes freezing while loading the kde). I looked into the hard drive install, because I wanted to install some software, and I read somewhere that once knoppix is installed on the hard drive it is pretty much like Debian GNU/linux, so I downloaded that (The 7-disc non-us 3.0r4 version and the two update cds). I installed it all fine, it boots ok and I can use the shell but when it boots, during login to the shell a message pops up saying 'I cannot load the Xserver...maybe it hasn't been configured correctly'. It asks if I want to view the error message output of the xserver, but when I view it there is nothing there.

When I run 'startx' in bash I just get some error messages:

/usr/X11R6/lib/X11/xinit/xserverrc: /usr/bin/X11/X: No such file or Directory
/usr/X11R6/lib/X11/xinit/xserverrc: exec /usr/bin/X11/X: cannot execute: No such file or Directory
giving up
xinit: connection refused(errno 111): unable to connect ot Xserver
xinit: No such process(errno 3): server error

I searched around the web and read that Xfree 3.3.2 doesnt support the Neo magic video card that Acer uses, but the page was dated 1999 so is probably useless.

Please help!

Matt