Help - Search - Members - Calendar
Full Version: Vsftpd
Linuxhelp > Support > Technical Support
jjwl89
Hello
I installed vsftpd on a machine running mandrake 10.1. I'm fairly new with linux. I would like users to be able to log in and access a directory. My conf file reads as follows:

anonymous_enable=NO
local_enable=YES
write_enable=YES
local_umask=022
dirmessage_enable=YES
xferlog_enable=YES
connect_from_port_20=YES
xferlog_std_format=YES
chroot_list_enable=YES
chroot_list_file=/etc/vsftpd.chroot_list
hide_ids=YES
ls_recurse_enable=YES
pam_service_name=vsftpd
userlist_enable=YES
listen=YES
tcp_wrappers=NO

When I try to ftp my machine it gives me the following error:

[root@localhost jason]# ftp localhost
Connected to localhost.
220 (vsFTPd 2.0.1)
530 Please login with USER and PASS.
530 Please login with USER and PASS.
KERBEROS_V4 rejected as an authentication type
Name (localhost:jason): jason
530 Permission denied.
Login failed.
ftp> quit
221 Goodbye.
[root@localhost jason]#

What files should I place the users I want to be able to log in into? Also, does each user need an account on the machine and when they log in what directory can they access? Finally, where do I place the passwords for the users to login with?

Thanks
Termina
Check /etc/passwd

I'm betting that you don't have a default shell specified. Try setting it to /bin/bash

(you can do this with a command, w/o writing to /etc/passwd: usermod -s /bin/bash jason)

You might have to restart vsftpd, but probally not.

Try again, and you're in!
Avarus
When I try to connect by the terminal it all goes ok, but when I try to connect on another computer, it turns out I can't (although he recognises username and password). Ports in the router are open, firewall allows VSFTPD, but still no connection.

/etc/vsftpd/vsftpd.conf:

CODE
chown_uploads=NO
xferlog_enable=YES
idle_session_timeout=600
data_connection_timeout=120
ascii_upload_enable=YES
ascii_download_enable=YES
background=YES
listen=YES
ls_recurse_enable=NO
chroot_local_user=YES
write_enable=YES

anonymous_enable=NO
anon_upload_enable=NO
anon_mkdir_write_enable=NO

userlist_enable=YES
userlist_deny=YES
local_enable=YES
pam_service_name=vsftpd
DS2K3
Have you tried using Passive mode? FTP uses several ports (contl ports and data ports) and is notoriously trick to port-forward.

D
Avarus
QUOTE (DS2K3 @ Oct 21 2006, 09:45 PM) *
Have you tried using Passive mode? FTP uses several ports (contl ports and data ports) and is notoriously trick to port-forward.

D


How to use the passive mode? Do I have to change it in vsftpd.conf?
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.