Help - Search - Members - Calendar
Full Version: Rhel 4 Won't See Ps/2 Keyboard
Linuxhelp > Support > Technical Support
nifflerX
Hi,

I recently installed RHEL WS 4 on a machine and the installation went fine until I tried to use my keyboard. My keyboard is a Microsoft keyboard that connects via PS/2 port. When I'm booting up the machine with the keyboard connected I can use the keyboard to enter the BIOS and to select which kernel to run. But as soon as the kernel is loaded I lose the ability to use the keyboard. If I plug in a USB keyboard I can use that without a problem. I've run kudzu a number of times and it doesn't see any problems, regardless of if the PS/2 keyboard is plugged in or not. If I run kudzu and unplug the USB keyboard they it asks about the USB configuration.

I checked the file /etc/sysconfig/keyboard and the settings appear to be right:

KEYBOARDTYPE="pc"
KEYTABLE="us

Does anyone know how I can force my machine to recognize a PS/2 keyboard? Thanks so much.

-NifflerX
nifflerX
So it turns out to get the PS/2 keyboard working you must disable 'USB Legacy Support' in the BIOS (at least for the version I'm running, 1.08). Hope this helps someone out.


-NifflerX
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.