Help - Search - Members - Calendar
Full Version: Leadtek Winfast Tv 2000 Expert Not Working.
Linuxhelp > Support > Technical Support
Polloch
Hi,

I am trying to work my brand new tv tuner, but it seems like it won't.

Iread quite a few guides and posted a lot about it but still...

the main problem seems to be that bttv can't find its way through to video modules (/dev/video )
I checked on them and there are 4 + 1link
however the output invariably is $ xawtv
This is xawtv-3.93, running on Linux/i686 (2.6.3-7mdk)
can't open /dev/v4l/video0: No such file or directory
v4l-conf had some trouble, trying to continue anyway
v4l2: open /dev/v4l/video0: No such file or directory
v4l2: open /dev/v4l/video0: No such file or directory
v4l: open /dev/v4l/video0: No such file or directory
no video grabber device available

I don't know what to do. I tried creating a link, changing permissions, generating more devices with a makedev script I found on the web.

In my dmesg file i found:


Feb 1 14:49:08 br137-1-82-228-156-228 kernel: i2c-core: Unknown parameter `i2c_debug'
Feb 1 14:49:08 br137-1-82-228-156-228 modprobe: WARNING: Error inserting i2c-core (/lib/modules/2.6.3-7mdk/kernel/drivers/i2c/i2c-core.ko.gz): Unknown symbol in module, or unknown parameter (see dmesg)
Feb 1 14:49:08 br137-1-82-228-156-228 modprobe: WARNING: Error inserting i2c-algo-bit (/lib/modules/2.6.3-7mdk/kernel/drivers/i2c/algos/i2c-algo-bit.ko.gz): Unknown symbol in module, or unknown parameter (see dmesg)
Feb 1 14:49:08 br137-1-82-228-156-228 kernel: i2c-algo-bit: Unknown symbol i2c_del_adapter
Feb 1 14:49:08 br137-1-82-228-156-228 kernel: i2c-algo-bit: Unknown symbol i2c_add_adapter
Feb 1 14:49:08 br137-1-82-228-156-228 modprobe: FATAL: Error inserting bttv (/lib/modules/2.6.3-7mdk/kernel/drivers/media/video/bttv.ko.gz): Unknown symbol in module, or unknown parameter (see dmesg)
Feb 1 14:49:08 br137-1-82-228-156-228 kernel: bttv: Unknown symbol i2c_bit_add_bus
Feb 1 14:49:08 br137-1-82-228-156-228 kernel: bttv: Unknown symbol i2c_master_recv
Feb 1 14:49:08 br137-1-82-228-156-228 kernel: bttv: Unknown symbol i2c_del_adapter
Feb 1 14:49:08 br137-1-82-228-156-228 kernel: bttv: Unknown symbol i2c_bit_del_bus
Feb 1 14:49:08 br137-1-82-228-156-228 kernel: bttv: Unknown symbol i2c_clients_command
Feb 1 14:49:08 br137-1-82-228-156-228 kernel: bttv: Unknown symbol i2c_add_adapter
Feb 1 14:49:08 br137-1-82-228-156-228 kernel: bttv: Unknown symbol i2c_master_send

I guess the person who wrote the guide about the tuner card might be able to help. It would be so nice!
Corey
Well, the problem is definitly with the modules themselves, and not with any links or permissions.

Ensure that you have your Mandrake kernel source and headers installed (as well as build tools like gcc, automake, autoconf, libtool, m4, etc.)

After that, you can visit the v4l2 homepage and download the latest bttv drivers, and compile and install them.

After the make install process, run 'depmod -a' and then 'modprobe -v bttv' and then checkout the dmesg output and see how that went.

If you want more of an explanation, it appears that the modules were not compiled using the same kernel tree as the currently running kernel, therefore there's a lot of unknown symbols.
Polloch
Hi,
thanks for answering.

I reinstalled my system as a mandrake 10.0 and recompiled my kernel using 2.6.10 sources. I followed the tv tuner guide. and then... Nothing happened.
Or more precisely, Istill get the same old output: no /dev/video/v4l.

I don't really mind spending a lot of time working on it, but Ihate not understanding what goes wrong.

I'll try to be a bit more comprehensive in this post:
(this was the first time Irecompiled my kernel, and Iwas pretty much focused on the tv card thing, so my config is not exactly sharp- I'll work on it later.)

# dmesg
[...]
tuner: `' invalid for parameter `type'
i2c-core: driver i2c TV tuner driver registered.
Linux video capture interface: v1.00
bttv: driver version 0.9.15 loaded


# lsmod
Module Size Used by
isofs 36696 0
zlib_inflate 18272 1 isofs
bttv 156464 0
video_buf 21540 1 bttv
firmware_class 9760 1 bttv
i2c_algo_bit 9960 1 bttv
v4l2_common 5696 1 bttv
btcx_risc 4776 1 bttv
videodev 9696 1 bttv
tuner 22436 0
i2c_core 25456 3 bttv,i2c_algo_bit,tuner
[...]


etc/x11/x86 config:
Section "Files"
# Multiple FontPath entries are allowed (they are concatenated together)
# By default, Mandrake 6.0 and later now use a font server independent of
# the X server to render fonts.
FontPath "unix/:-1"
EndSection

Section "ServerFlags"
#DontZap # disable <Crtl><Alt><BS> (server abort)
AllowMouseOpenFail # allows the server to start up even if the mouse doesn't work
#DontZoom # disable <Crtl><Alt><KP_+>/<KP_-> (resolution switching)
EndSection

Section "Module"
Load "dbe" # Double-Buffering Extension
Load "v4l" # Video for Linux
Load "extmod"
Load "type1"
Load "freetype"
Load "glx" # 3D layer
Load "dri" # direct rendering
EndSection

Section "DRI"
Mode 0666
EndSection

Section "InputDevice"
Identifier "Keyboard1"
Driver "Keyboard"
Option "XkbModel" "pc105"
Option "XkbLayout" "fr"
Option "XkbOptions" ""
EndSection

Section "InputDevice"
Identifier "Mouse1"
Driver "mouse"
Option "Protocol" "ExplorerPS/2"
Option "Device" "/dev/mouse"
Option "ZAxisMapping" "6 7"
EndSection

Section "Monitor"
Identifier "monitor1"
VendorName "Generic"
ModelName "1024x768 @ 70 Hz"
HorizSync 31.5-57.0
VertRefresh 50-70

# Sony Vaio C1(X,XS,VE,VN)?
# 1024x480 @ 85.6 Hz, 48 kHz hsync
ModeLine "1024x480" 65.00 1024 1032 1176 1344 480 488 494 563 -hsync -vsync

# TV fullscreen mode or DVD fullscreen output.
# 768x576 @ 79 Hz, 50 kHz hsync
ModeLine "768x576" 50.00 768 832 846 1000 576 590 595 630

# 768x576 @ 100 Hz, 61.6 kHz hsync
ModeLine "768x576" 63.07 768 800 960 1024 576 578 590 616
EndSection

Section "Device"
Identifier "device1"
VendorName "Intel Corporation"
BoardName "Intel 810"
Driver "i810"
VideoRam 16384
Option "DPMS"

Option "XaaNoPixmapCache"
EndSection

Section "Screen"
Identifier "screen1"
Device "device1"
Monitor "monitor1"
DefaultColorDepth 16

Subsection "Display"
Depth 8
Virtual 800 600
EndSubsection

Subsection "Display"
Depth 15
Virtual 800 600
EndSubsection

Subsection "Display"
Depth 16
Virtual 800 600
EndSubsection

Subsection "Display"
Depth 24
Virtual 800 600
EndSubsection
EndSection

Section "ServerLayout"
Identifier "layout1"
InputDevice "Keyboard1" "CoreKeyboard"
InputDevice "Mouse1" "CorePointer"
Screen "screen1"
EndSection




modprobe.conf

options i810fb xres=800 hsync1=32 hsync2=48 vsync1=50 vsync2=70 vram=2 bpp=16 accel=1 mtrr=1
alias sound-slot-1 snd-cmipci
alias eth0 3c59x
alias sound-slot-0 i810_audio
options cx8800 radio=0 card= gbuffers=4
install snd-cmipci /sbin/modprobe --first-time --ignore-install snd-cmipci && { /sbin/modprobe snd-pcm-oss; /bin/true; }
install usb-interface /sbin/modprobe usb-uhci; /sbin/modprobe usb-ohci; /sbin/modprobe ehci-hcd; /bin/true
remove snd-cmipci { /sbin/modprobe -r snd-pcm-oss; } ; /sbin/modprobe -r --first-time --ignore-remove snd-cmipci



modprobe preload
intel-agp


modules
(empty)


modules.conf
options i810fb xres=800 hsync1=32 hsync2=48 vsync1=50 vsync2=70 vram=2 bpp=16 accel=1 mtrr=1
probeall usb-interface usb-uhci usb-ohci ehci-hcd
alias sound-slot-1 snd-cmipci
above snd-cmipci snd-pcm-oss
alias eth0 3c59x
alias sound-slot-0 i810_audio
alias char-major-81 bttv
pre-install bttv modprobe -k tuner
options bttv radio=1 gbuffers=4
load v41


modules.devfs (relevant part only)

# Video capture devices
alias /dev/video* /dev/v4l
alias /dev/vbi* /dev/v4l


Modprobe devfs

# Video capture devices
alias /dev/video* /dev/v4l
alias /dev/vbi* /dev/v4l


In /dev/..

I have
vbi (link) + vbi*
video (link)+ video*


I also wonder if my card has a bt878 chipset. Most users of this model seem to be saying it has a conexant chipset. In that case, could that explain my problems?


Thanks very much for reading. biggrin.gif
Corey
Perhaps it registered a different device rather then /dev/video/v4l , i know for me, it always registeres /dev/video0 for my tvtuner.

I'm not sure of the xawtv syntax, just run xawtv --help and see what switch you will need to define what device to use.

with tvtime it is tvtime -d /dev/video0


If it's not video0 , go into the /dev directory and do a ls -l | grep video
Polloch
Hi

well eventually, it found the devices.... but it still doesn't work.
At least this is somehow encouraging!


$ xawtv
This is xawtv-3.93, running on Linux/i686 (2.6.10-1mdk)
/dev/v4l/video0 [v4l2]: no overlay support
v4l-conf had some trouble, trying to continue anyway

As you can see I updated my kernel and I installed Udev -although I am not sure udev helped a lot since the v4l folder is now in /dev/ and NOT in /udev/.... Puzzling eh?

I am now positive that my chip is NOT bt878 but cx88xx. So I grabbed
the cx88-0.0.4 driver from bytesex.org, it seems to be the latest update.



I am tryng to compile it, even though the compiling instructions I found on the v4l homepage don't work for me :

# make KDIR
make: *** Pas de règle pour fabriquer la cible « KDIR ». Arrêt.
(my shell speaks french: approx. no rule to make target)

I just found some details I hadn't noticed before:

# xawtv
This is xawtv-3.93, running on Linux/i686 (2.6.10-1mdk)
/dev/v4l/video0 [v4l2]: no overlay support
v4l-conf had some trouble, trying to continue anyway
X Error of failed request: BadWindow (invalid Window parameter)
Major opcode of failed request: 2 (X_ChangeWindowAttributes)
Resource id in failed request: 0x2600063
Serial number of failed request: 8801
Current serial number in output stream: 8801


It would be great if you had an idea.

Thanks a lot for your help!
Corey
Everything that I read on Winfast cards is that they all use the bttv driver, especially the tv 2000* cards.

It should use a card=34 and a tuner type of either 2 (NTSC) or 5 (PAL)

Are you sure it's cs* ?
Polloch
Hi

I am positive.
The reason why we both were mislead is that this card used to be built with bt878 chipsets, but was recently swapped to cx88. bttv's developper now develops a specific cx88 driver, it is included in the 2.6.10 kernel, and updates are regularly posted on the v4l site
It is very important to get packages (or tarballs) as fresh as possible.

I followed and adapted your advice:


[QUOTE=Corey @ http://www.linuxhelp.net/guides/tvtuner/#canada
So, in order for the tuner to be auto-detected as type=2 (the correct tuner type for the NTSC version) we need to edit the modules source first. In your favorite text editor, open up the following file in your kernel source tree (/usr/src/linux/drivers/media/video/bttv-cards.c). What happens is that the driver defaults to type=5 in the source, so if the card doesn't auto-detect properly, it sets it to 5.]

So what I did was go to /usr/src/linux/drivers/media/video/[Ucx88-cards.c], and change default tuner setting from 44 to 3 (France=Secam).


And IT WORKS!!!!!!!!
Or at least, the image does.

Now I have to settle the sound issue . But I think I might have plugged the audio out (to the sound card) the wrong way round...well I'm noob you know....

And there is stll the problem of canal+ which is a pay , encrypted channel that broadcasts free unencrypted prime-time programs, so I should legally and normally be able to scan it and I don't.
Minor problems...

Thanks a lot for helping.

I'm not through, yet but i'm sure I will soon be...with a little help.

Thanks again.
Corey
Wow, this is definitly news to me. I'm really starting to dislike the Winfast tv tuners, seems like nothing but trouble under linux. No offense to Gerd Knorr (he does a great job developing the drivers), but the companies really should release open source drivers.

I'm not quite sure how to fix the sound issue, i've never run into that one before.

Perhaps your module is automuting it. I noticed this with mine for some channels that weren't getting a strong signal, so i added another modprobe option:

modprobe -v bttv tuner=2 card=34 radio=1 automute=0

Not sure if that's your problem or not.
paulus
Hello everybody..

I have WinFastTV and got it working (more or less). Sound is a little noisy, but i have sound and video.

Strange....

modprobe -r cx88xx
modprobe -r cx8800

Netx...

modprobe cx88xx tuner=44
modprobe cx8800 tuner=44

And again...
modprobe -r cx88xx
modprobe -r cx8800

And finally

modprobe cx88xx tuner=38
modprobe cx8800 tuner=38

I know i sounds weird, but it's the best I could do.
Still working on it, to get better result, and make it "automatic"..
Now I'm thinking how to type approrpiate modprobe.preload

Regards. (sorry for influent english)
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.