Help - Search - Members - Calendar
Full Version: Kernel 2.4.20 Will Not Run
Linuxhelp > Support > Technical Support
Newtek007
I'm not really new to using Linux but I'm new to compiling stuff like the kernel. I am having a problem doinf so with the 2.4.20 distro. I have googled everywhere and have papers about half inch thick telling how to compile the kernel. All of them point to using LILO as the boot loader but I am using GRUB that came with my RedHat 8.0 distro. I like it better than LILO and want to continue to use it.
Here is the problem. I have everything compiled and in their places with no errors but when I try to load the kernel with grub this is what I get:

can't open root device "LABEL=/" or 00:00
Please append a correct "root=" boot option
Kernel panic: VFS: Unable to mount root FS on 00:00

I have looked over the GRUB lines over and over with examples and they are correct. Any ideas?
Thanks.
chrisw
did you manually update your grub.conf file
after you compiled your kernel
and did you move your kernel image files
to your /boot directory?
Newtek007
Yeah, I manually configured GRUB. I also moved the bzImage file to the boot renaming it to vmlinuz-2.4.20.
chrisw
did you move the System-map file also?
Newtek007
Yep. Like I said I have done everything that has been suggested and it still will not boot.
chrisw
did you compile and install the modules into the kernel image?

i tend to forget those two steps....


post your steps you have done, in their proper order and
i will see if i see anything odd...

also, do you have a scsi or ide system?
Newtek007
Ok. Here are my steps in trying to compile 2.4.20.

1. Downloaded kernel source from www.kernel.org. 2.4.20
2. Decompressed it into /usr/src. The folder is now reading <linux-2.4.20>.
3. Changed into that directory with command prompt.
4. <mrproper>
5. <make xconfig>. Fill out all of the options. Also have tried by <make oldconfig>.
6. <make bzImage>.
7. <make modules>.
8. <make modules_install>.
9. <make install>.

The one thing that I do notice is that the RedHat 8.0 <initrd-2.4.18.img is about 2XX k big while the initrd image that 2.4.20 generated is only about 62k big. I am thinking that the initrd image isn't being written properly.

I have followed the directions from the RedHat 8.0 customizing the kernel how to and tried the instructions from the README file with 2.4.20 and from http://www.tldp.org/HOWTO/Kernel-HOWTO-2.html.

Still can't get it to work.

One note of interest is that if I copy the 2.4.18 RedHat folder and build from that folder that kernel will boot up and run. Has RedHat done anything that is proprietory (can't spell) to the Makefile???

Thanks.
chrisw
i havent compiled a kernel in a while but i think you skipped
a few steps

4. <mrproper>
5. <make xconfig>. Fill out all of the options. Also have tried by <make oldconfig>.
should have done the following steps
make dep
make clean

6. <make bzImage>.
7. <make modules>.
8. <make modules_install>.
9. <make install>.

instead of make install....i havent ever done that....

try manually copying your System.map and your bzImage
to your /boot directory

and the when you copy them add the kernel version number
after them

for example:

cp <path to System.map>System.map /boot/System.map-2.4.20

same with your bzImage:

cp <path to bzImage>/bzImage /boot/vmlinuz-2.4.20


edit grub or lilo....which ever you are using....
keep your existing kernel info in the lilo or grub conf files
in case something goes wrong...you can still boot up linux
with the old kernel

you dont need to make a new initrd.img unless you have
a scsi system....i think...

cause i have both ide and scsi systems....and never made
and new initrd.img file for my ide systems
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.