Help - Search - Members - Calendar
Full Version: Reiserfs Corruption
Linuxhelp > Support > Technical Support
quadrinary
We had some rapid power outages at our office yesterday, and somewhere in the restarts (the computer was on a UPS with a bad battery and the BIOS was set to turn the computer on after the power was restored) the “/” partition on my RAID array got seriously messed up. The /var partition was ok, so it wasn’t a broken raid array (or so it seemed) however everything I’ve tried has resulted in no luck. I tried a “reiserfsck –rebuild-sb” followed by “reiserfsck –rebuild-tree”. Following that, I once again attempted to mount that partition and it failed. Even before attempting to mount I would reboot and run “reiserfsck –check” and it returned no errors. i was in a bit of an irate state and i think i also might have tried --no-journal-available, in which case i don't know how i should go about making a new journal etc. I went through this process a couple times thinking that perhaps something had been missed the first time around. I’m at a complete loss here, and I’m VERY concerned because I’m unable to access my company’s files and financial system – and due to an ironic twist of fate, we have no backup except for one from about a month ago.



Any help you could provide would be appreciated. I’m not concerned with making this partition bootable again, just with retrieving the data.



Thank you!

-quad
quadrinary
anyone?
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.