Help - Search - Members - Calendar
Full Version: Asus Tv/fm Card
Linuxhelp > Support > Technical Support
markm
I've tried tvtime and xawtv but neither can get a tv signal. I've tested the cable and it has a strong signal.
I compiled kernel 2.6.9 from deb source.
v4l and saa7134 load as modules.
Card isn't detected by driver so I modprobe -r saa7134 and reload with modprobe saa7134 card=25 tuner=2

dmesg shows:
Linux video capture interface: v1.00
saa7130/34: v4l2 driver version 0.2.12 loaded
ACPI: PCI interrupt 0000:00:0e.0[A] -> GSI 17 (level, low) -> IRQ 17
saa7133[0]: found at 0000:00:0e.0, rev: 240, irq: 17, latency: 32, mmio: 0xed000000
saa7133[0]: subsystem: 1043:4845, board: ASUS TV-FM 7133 [card=25,insmod option]
saa7133[0]: board init: gpio is 0
saa7133[0]: dsp access wait timeout [bit=WRR]
saa7133[0]: dsp access wait timeout [bit=WRR]
saa7133[0]: i2c eeprom 00: 43 10 45 48 54 20 1c 00 43 43 a9 1c 55 d2 b2 92
saa7133[0]: i2c eeprom 10: 00 ff e2 0f ff 20 ff ff ff ff ff ff ff ff ff ff
saa7133[0]: i2c eeprom 20: 01 40 01 02 03 01 01 04 08 ff 00 89 ff ff ff ff
saa7133[0]: i2c eeprom 30: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
tuner: Ignoring new-style parameters in presence of obsolete ones
tda9887: Ignoring new-style parameters in presence of obsolete ones
tda9885/6/7: chip found @ 0x96
saa7133[0]: registered device video0 [v4l2]
saa7133[0]: registered device vbi0
saa7133[0]: registered device radio0

lsmod shows:
tda9887 13272 0
tuner 20580 0
saa7134 101392 0
video_buf 21764 1 saa7134
v4l2_common 6016 1 saa7134
v4l1_compat 14212 1 saa7134
ir_common 4932 1 saa7134
videodev 9664 1 saa7134

Any suggestions appreciated.

Thx, mark
markm
It's been absolutely quiet, perhaps I didn't provide enough info.

Here's what lspci reports:
0000:00:0c.0 Multimedia controller: Philips Semiconductors SAA7133 Audio+video broadcast decoder (rev f0)
Subsystem: Asustek Computer, Inc.: Unknown device 4845
Flags: bus master, medium devsel, latency 32, IRQ 19
Memory at ed800000 (32-bit, non-prefetchable) [size=2K]
Capabilities: [40] Power Management version 2

I tried patching the kernel with All-2.6.9-rc4.diff from bytesex.org but it didn't changed anything.

When I run tvtime the application appears to work. I can scan channels switch between the video sources etc. When it's set to television it displays a blue screen with a "no signal" message.

Although /dev/video0 looked ok I deleted and remade it using the same major/minor numbers, 81 0. And Yes, I've tried with root permissions.

After reading through Gerd's documentation I tried loading the driver with tuner=39 param (tuner_lg_ntsc_new_tapc) but it didn't change anything.

I'm at a loss. It's probably something silly and I just can't see it. What I need is someone to take me by the hand and lead me out of the woods.

Mark
Corey
If you have access to IRC, jump onto irc.freenode.net and join the channel #livid . The developers of tvtime are usually there and should be better able to help you because they have extensive experience with dealing with various problems with tv tuners in linux.

I'm normally pretty good with this stuff, but i'm not sure what could be wrong in your case.
markm
Thanks for the suggestion Corey but I didn't make it over.

I gave up on this card and got a Winfast TV 2000xp Expert. I had already compiled the CX88 module so it was a simple matter of pulling the Asus out, plugging the Winfast in and 5 minutes later I was watching TV (a dubious accomplishment when you think of it).

I have since found another thread in LinuxQuestions.org from last summer that describes almost exactly my experience. I know little about the technology but one obvious difference with the Asus card and all others I have seen is that it doesn't have the shielded tuner module. Yet other Asus TV cards usiing both PAL and NTSC do have the tuner module. It makes me think that Asus has done something completely different with respect to a tuner on this card.

Mark
Corey
Well, either way, it was a good choice going with the Winfast card, I have a Winfast tv 2000 xp deluxe card and it works quite fine for me in linux using the bttv and tuner modules. I found that the winfast cards were less expensive and the performance was perfect for what I was looking for.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.