Help - Search - Members - Calendar
Full Version: Debian, Apache, And Php 4
Linuxhelp > Support > Technical Support
ddemland
I have install the PHP 4 Debian package and made all the changes to the http.conf file for PHP. These changes included the new lines being added:

LoadModule php4_module /usr/lib/apache/1.3/libphp4.so

AddType application/x-httpd-php .php
AddType application/x-httpd-php .php4
AddType application/x-httpd-php .php3
AddType application/x-httpd-php-source .phps
AddType application/x-httpd-php .phtml

DirectoryIndex index.html index.php index.php3 index.php4 index.phtml index.htm index.shtml index.cgi

I have read about adding a line like:

AddModule mod_php4.c

But this only gets the message:

[warn] module mod_php4.c is already added, skipping

In any case the basic problem is simple. I can get any file with a .php3, or .php4, extension to run, but when I try a file with a .php extension all I get is a prompt to download the file.

What am I missing?

Thank You,

David
DS2K3
Justa tip -

AddType application/x-httpd-php .php
AddType application/x-httpd-php .php4
AddType application/x-httpd-php .php3

Can all go on one line, like AddType application/x-httpd-php .php .php4 .php3 .phtml

As for your problem, it is something to do with your mimie-type settings. The file is being sent as something oother than text/tml or text/plain which the browser can understand, so the browser decides it doesnt know what it is, and asks you where you want it saved.

Could you post a link to your httpd.conf file (posting it here might be a bit long...) and also check to see that x-htttpd-php is setup correctly in your systems mime-type settings

D
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.