Help - Search - Members - Calendar
Full Version: Sound Issue - Unknown Cause
Linuxhelp > Support > Technical Support
azakem
Hi all, I'm running Red Hat 9 with a Soundblaster Live 5.1 card, and out of the blue any application that uses sound randomly locks up my system. XMMS, mplayer, flash applications, you name it. The only change I made to my system before this error began was swapping my external speakers. Anybody have any suggestions?

Thanks.
Jim
Well obviously your system is confused by the external speaker change. Your system must be able to "see" that they are different, do you have a web cam? It might be seeing it through that. Ok, enough of that.

Humm, thats odd. I hate to pull out the old trick, but reinstalling/updating the module might be in order. If you are running Red Hat you should just be able to reinstall the RPM for the sound module. The module that RH9 uses for the card is emu10k1.o Make sure its loaded (modprobe emu10k1 if it isn't loaded, or wont load correctly, thats the problem. Reinstall the package and see what you can get.
azakem
Well I tried showing the speakers to the sound card, but it insists they've never met before.

Anyways, modprobe was unable to locate emu10k1, so I downloaded the source and followed the directions in the readme file for install. Everything installed fine, and then I added the line 'alias sound emu10k1' to /etc/modules.conf per the readme instructions. Only problem is, now XMMS won't play any files, giving a 'couldn't open audio' error, and when I modprobe emu10k1, I get the following errors:

/lib/modules/2.4.20-31.9/kernel/drivers/sound/ac97_codec.o: create_module: Operation not permitted
/lib/modules/2.4.20-31.9/kernel/drivers/sound/ac97_codec.o: insmod /lib/modules/2.4.20-31.9/kernel/drivers/sound/ac97_codec.o failed
/lib/modules/2.4.20-31.9/kernel/drivers/sound/ac97_codec.o: insmod emu10k1 failed

Needless to say, I have no idea what this means, but clearly I did something I wasn't supposed to do.
Any more suggestions?

Thanks.
hughesjr
is there a redhat-config-soundcard in redhat 9 ... you would type that as root from a terminal

Or is there a Menu -> System Settings -> Soundcard Detection from your GUI Menu
azakem
There is a redhat-config-soundcard, when I run it as root it outputs the following:

Traceback (most recent call last):
File "/usr/share/redhat-config-soundcard/redhat-config-soundcard.py", line 44, in ?
app = soundcard.childWindow()
File "/usr/share/redhat-config-soundcard/soundcard.py", line 162, in __init__
self.primaryDeviceMenu.set_active(self.cardList.index(self.soundcardBackend.getD
efaultCard()))
ValueError: list.index(x): x not in list


Also there is soundcard detection in the GUI menu, however when I run it, it prompts me for the root password, and then does nothing.
Hemant
I would suggest,you upgrade your Linux system.Redhat-9.0 is pretty old.
azakem
Yeah I was thinking of going to Fedora core anyways. Thanks for the help though.
hughesjr
Looks like your python is not the version that the tools need ... did you upgrade (or downgrade) your python for some reason?

And I agree ... use FC2 or FC3 on your machine if possible (if it is a workstation), or CentOS if it is a Server.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.