Help - Search - Members - Calendar
Full Version: Mount A Tape Drive
Linuxhelp > Support > Technical Support
Anyone know howto mount a tape drive from RedHat AS3 on a 810 iSeries machine?
Tape drives are not mounted. They are character devices and the application reads the data from the tape like a regular file.

What are you trying to accompilish? What type of tape drive i.e. make/model.
I forgot the model but it is a 30GB QIC tape drive (60GB with typical 2x compression).
So how do you list the file in the QIC tape? ls command? which directory should I go?
I assume this is a working unit?
Do you know what backup program was used?

There isn't a directory associated with a tape drive. You need to read the tape but without knowing the tape format just determining the contents can be difficult.

Without knowing the details I would guess tape device is either /dev/ht0 or /dev/st0. Is there any other information you can provide?

I am also unfamiler with a 810 iSeries machine.
The model for the tape drive is 4584. I'm not sure what kind of backup program they used, because my part only installed the Linux partition on the 810 machine.

So I have to mount all the drive for them. Let's say there are some objects or tar files in the tape and I would like to view it. How can I do so?

Btw, did you have any experience on the vncserver? I tried it on a PC connect to the Linux partition and it worked succesfully but the screen is quite jerky. Do you know how can I solve it? Or do I need to upgrade the vnc package?
VNC has always worked well enough so I have never had to worry about tweaking it.

Assuming the tape drive device is /dev/st0
tar -tvf /dev/st0

If /dev/st0 fails try /dev/ht0
VNC needs quite a lot of resources, mainly becuase it is essentially taking screenshots and sending them across the network. Check your NIC speed, and maybe check you have enough free resources on the server.

There are other ways to get linux programs to show up on a Windows workstation, thanks to the modularioty of the X server.

I will give it a try. Thanks for the help guys...!
Hi guys,

i'm a newbie on linux and i hope i'm not off topic, but i have a DLT HP C5683A in st0 and i try to make the tar -tvf /dev/st0 and after that it came up with an error that said:

tar: /dev/st0: cannot read: Cannot allocate memory
tar: At beggining of tape, quitting now
tar: Error is not recoverable: exiting now

and i know that my server recognizes the tape device, because i run # cat /proc/scsi/scsi and it gives the attached devices, and if i make scsi_info /dev/st0 he gives me the scsi ID ("0,3,0"), the model ("HP C5683A") and firmware revision ("C305")...

So i really wanted to know how to put this tape working... can you guys help me?



p.s. by the way what is the backup software that you guys recommend... i'll will probably try ArcServe for Linux but i'm open to a good and simple to install software...
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2018 Invision Power Services, Inc.