Help - Search - Members - Calendar
Full Version: Fstab Error
Linuxhelp > Support > Technical Support
andy1974
HELP!!!!!!....... My server wont boot....it starts to boot then stops at this error.....

WARNING: bad format on line 14 of /etc/fstab
fsck.ext3: no such file or directory while trying to open /dev/hdd1

I can log in as root ......but i dont know how to edit FSTAB in the console to remove line 14...
cowdudy
Login as root, and use your editor.
TYPE: vi /etc/fstab

then press enter. Are you sure the hard drive is working? Make sure it is listed in the bios with the proper
parameters.
michaelk
Futhermore:
Use the cursor to move down to the line 14
Press the insert key and type in a #. This will convert line 14 to being just a comment.
Press the Esc key.
To save and exit vi enter the following.
:wq

Now post line 14. There coud be other issues.
andy1974
ok thanks
it worked
i had to redo line 14 after a kernal upgrade
beltucadros
I'm having a "simillar" problem. My usb flash drive udes to be /dev/sda1, but since a kernel upgrade there is no /dev/sda1, or any sda*'s at all. I upgraded from 2.4.* to 2.6.10 I know 2.6 changed the usb interfcae but i don't know where to find it.
DS2K3
Get root access (su -) then run the following

CODE
tail -f /var/log/messages


Then plugin your drive, and see what it says, if anything... Post the output here

D
beltucadros
Jan 9 17:20:32 argona kernel: usb 1-4: new high speed USB device using address5
Jan 9 17:20:32 argona kernel: uba: device 5 capacity nsec 506880 bsize 512
Jan 9 17:20:32 argona kernel: uba: uba1
Jan 9 17:20:33 argona usb.agent[14478]: ... no modules for USB product 5dc/a400/100
Jan 9 17:20:34 argona udev[14523]: creating device node '/dev/uba1'
Jan 9 17:20:34 argona udev[14522]: creating device node '/dev/uba'

i tried using uba1 instead of sda1 i got an error the first time i tried but it seems ok now
thanks
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.