Help - Search - Members - Calendar
Full Version: Monitor
Linuxhelp > Support > Technical Support

I'm kinda new to Linux. I decided to try out Red Hat 9, but my monitor got "out of scan range" when I tried to install it in graphical mode. Well, I installed it in text mode but I can't get to X now. I did a quick google about the problem and found out that I could go to kernel and try to edit the file etc/X11/XF86Config. Well, lowering the rates and resolution didn't resolve the problem, and I renamed it and tried running redhat-config-xfree86 and redhat-config-xfree86 -reconfig, but still no help.

Any ideas what I could try? My monitor is Sony Multiscan E200. And sorry about the bad english :)

first things first

check in the monitors manual the correct HorizSync and VerRefresh
and in your /etc/X11/XF86Config file search for something like this type in the proper values

Section "Monitor"
Identifier "Samsung"
HorizSync 31.5
VertRefresh 50-90

also you can try vesa for a first run [b](but DO CHANGE THE ABOVE HZ'S TO CORRECT VALUES!!!!)[b/]

Section "Device"
Identifier "Matrox" ---> yours will be different change this to vesa
Driver "mga"
VideoRam 8192
BusID "PCI:0:12:0"

then startx (and it should work without any problems)

if that works


cd /etc/
vi inittiab
and change that runlevel id something thingie to 5 instead of 3 you'll see that's right at the beggining

Robert B
First, thank you about your response.

I edited the file etc/X11/XF86Config, and changed the "Monitor" and "Device" sections to these:

Section "Monitor"
Identifier "Trinitron"
HorizSync 30.0 - 85.0
VertRefresh 48.0 - 120.0

Section "Device"
Identifier "Vesa"
Driver "mga"
VideoRam 8192
BusID "PCI:0:12:0"

What should I write in the "Screen" section? Now it has these lines:

Section "Screen"
Identifier "Screen0"
Device "Vesa"
Monitor "Trinitron"
DefaultDepth 24
SubSection "Display"
Depth 24
Modes "1024x768" "800x600" "640x480"

When I tried starting X, it crashed with an error log:

(EE) No devices detected

Fatal server error:
no screens found

Thanks in advance.

Edit: By the way, my graphics card is nVidia GeForce FX 5600. I remember that the installation worked a while ago when I had a different card (nVidia GeForce Ti4600). So, maybe it has something to do with my current graphics card?
That card is way to new to use w/redhat 9 smile.gif

Is there a reason you want to install RH9 ... because it doesn't get security updates and unless you really need that distro, I recommend something else (Like FedoraCore3).

If you must install RH9, make sure to install the kernel-source rpm ... then at the command prompt from root use the command (this is all one line if it wraps ... with a space between wget and http):


chmod 755

then after the driver compiles, edit XF86Config and change mga to nvidia for driver and remove the videoram and busid lines.

here is a readme

Pay particular attention to (sec-03) EDITING YOUR X CONFIG FILE of the readme and remove any lines that contain load dri or load GLcore and add load glx
You're going to have to install the NVIDIA module.

Download the .run file read the README (README.txt) follow the read me instructions, and you should be a happy linux user.

If not, come back, and we will help you out.
dang JIM ... you are fast, but not as fast as me biggrin.gif
Hey guys, thanks about the fast answers!

I'll try to install that NVIDIA patch, but if RH9 is so old and unsupported, I think I'll try Fedora instead. I'll post later on when I have installed the patch smile.gif
Well, it seems like the network isn't configured properly, the command wget gave me an error: "Resolving failed: Host not found". I'll just download Fedora Core 3 now and try again with it later tongue.gif

I guess I don't have to worry about uninstalling Red Hat? I can just choose the option "Install on a previous Linux partition" when installing Fedora?
Fedora wont have it by default either. Because RedHat is based in America is has to pay NVIDIA to include thier drivers by default, even windows doesn't do this. Not that I am telling you not to switch, I think its a good idea regardless, but you are still going to have to get the package and install it.

Ya, Hughes, good to have you back, and its on now.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2018 Invision Power Services, Inc.