Ive tried several times to get amaroK to run, but always get the following error:

amaroK could not be started, try typing "amaroK" at a command prompt, perhaps the output can help.

I ran the program one time, it ran fine - then I started to get the error. I tried it several more times and have gotten it to run once since. I went ahead and went to the command prompt, and got the following:

[amaroK loader] amaroK not running. Trying to start it..
amarok: [PluginManager] Plugin trader constraint: [X-KDE-amaroK-framework-version] == 3 and [X-KDE-amaroK-plugintype] == 'engine' and [X-KDE-amaroK-name] == 'void-engine' and [X-KDE-amaroK-rank] > 0
amarok: [PluginManager] Trying to load: libamarok_void-engine_plugin
amarok:
amarok: PluginManager Service Info:
amarok: ---------------------------
amarok: name : <no engine>
amarok: library : libamarok_void-engine_plugin
amarok: desktopEntryPath : amarok_void-engine_plugin.desktop
amarok: X-KDE-amaroK-plugintype : engine
amarok: X-KDE-amaroK-name : void-engine
amarok: X-KDE-amaroK-authors : (Max Howell,Mark Kretschmann)
amarok: X-KDE-amaroK-rank : 1
amarok: X-KDE-amaroK-version : 1
amarok: X-KDE-amaroK-framework-version: 3
amarok:
[amaroK loader] timed out trying to contact amaroK.
[amaroK loader] exiting.


Sorry for such a newb. question. Thanks in advance.