Help - Search - Members - Calendar
Full Version: Filesystem Error On Boot
Linuxhelp > Support > Technical Support
going_tech
I have a fileserver running CentOS 3.1 and Samba. The box has dual Pentium 200Mhz and CentOS is installed on a SCSI drive. I have an 80GB IDE drive installed for Samba. Apparently, someone decided to reboot the server by turning the power off to resolve problems with clients connecting. It was done repeatedly, even though it did not resolve the problem. All the files on the server disappeared (which are backed up so that is no big deal) and I get errors when booting up. When prompted to "Force file system integrity check" I press "Y" and allow it to contiue, but after some checks I get the folllowing errors.


Checking Filesystems
/home: recovering journal
/boot: 50/26104 files (10.0% non-contiguous), 29047/104391 blocks
JBD: failed to read block at offset 150
/home: Attempt to read block from file system resulted in short read while reading block 676

fsck.ext3: Attempt to read block from filesystem resulted in short read while trying to re-open /home
e2fsck: io manager magic bad!



***An error occured during the filesystem check
***Dropping you to a shell; the system will reboot
***when you leave the shell.

Give root password for maintainence
(or type Controll-D to continue)



What do I need to do to repair/restore these files? The files on the server are backed up so I am not worried about losing data, but I would like to fix this if I can. Thanks.
Corey
It looks like you're running ext3 filesystem, so when the bootup drops you to the shell, try a filesystem check with:

fsck.ext3 -p /dev/hdX (replace hdX with the partition you need to check)

Sometimes if it can't be done automatically, you may have to do the check manually (without the -p switch).

Try it and see if it fixes everything.
going_tech
I didn't see the harddrives listed on boot, and I don't remember what they are from when I installed. What command do I use to list the harddrives or devices?
going_tech
OK, I got a list of partitions on my SCSI drive, /dev/sda1 to sda3, and all have the Linux file system. I installed CentOS on the SCSI drive because it was only 4GB, and used an 80GB IDE for the fileserver, but I get no listing of any hd partitions. Does this mean that the IDE drive has failed?
going_tech
I tried all the combinations hda-hdc, hda1-4, hdd1-4, etc, but found nothing. So I ran the CentOS installer up to Disk Druid to get the partition info. Disk Druid found both the SCSI and the IDE drives and identified the size of each correctly. Disk Druid identified the IDE drive as hdb1, but when I restart and allow the system to boot, fdisk does not show any info for that partition. Does this make any sense? What could cause this? I am inclined to think that the drives are OK, but the system files have been damaged; however, I am very much a Linux novice.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.