Help - Search - Members - Calendar
Full Version: Dns Resolution Problems
Linuxhelp > Support > Technical Support
TheMadPimp
I am having a problem similar to this:
http://www.linuxhelp.ca/forums/index.php?a...t=ST&f=3&t=5344

I have also posted to here:
http://mandrakeusers.org/index.php?showtopic=19612

The problem goes like this: Internet access was fine when I first installed MDK10. I set it up as a Samba server for my Windows network. I don't really know at what point it stopped functioning properly but after everything was configured in Samba and functioning properly, I couldn't access the update sites (I got them from the easyurpmi website). I opened my web browsers (both konqueror and firefox) and tried to access various websites to no avail. When I entered the IP addresses of the sites they come up fine.

I Checked my resolv.conf and it seems to be fine. It has all the same DNS info as my workstations do.
Running 'route' provides me with this:
CODE
Destination          Gateway      Genmask          Flags      Metric    Ref    Use      Iface
192.168.1.0         *             255.255.255.0   U           0           0       0       eth0
127.0.0.0           *             255.0.0.0       U           0           0       0       lo
default             *             192.168.1.99    UG          0           0       0       eth0

I tried changing the DNS server to the address of my firewall and got no change. I changed it back to the DNS servers provided to me by Qwest and still nothing. I tried pinging the DNS servers and lo-and-behold, I can ping them. Why then, can't MDK perform the name resolution correctly?

As I stated before, this is a Windows network with a Samba server. All of the computers access the internet through a Firebox x firewall/VPN device(192.168.1.99).

If anyone can help I would greatly appreciate it.

Thanks,

TMP
Termina
You seem to be on a router.

Usually these have a DHCP server on them, to provide you with your DNS name servers. For some reason, it isn't doing this.

If you have a (working) Windows machine, try this: ipconfig /all

It'll list your DNS servers. You can then put those in /etc/resolv.conf

Mine looks like this:

QUOTE
search tds.net
nameserver 216.165.129.157
nameserver 134.215.200.126


You don't need the search in there, but I find that useful (in case they ever change).
TheMadPimp
I checked my Windows boxes and my resolv.conf on the linux server. The entries all look fine to me. The DNS servers are the same on The Windows boxes and on the MDK server. I can ping the DNS servers. For whatever reason, they are not performing DNS translation. Perfoming a tracert on windows shows 6 hops to reach the DNS servers. On linux, I get stuck at the 5th hop everytime.

TMP
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.