Help - Search - Members - Calendar
Full Version: Httpd Reverse Proxy
Linuxhelp > Support > Technical Support
Robert83
Hello,

well I decided I give a shot to this reverse proxying stuff today ...

this is the problem I get :

[root@thor reverseproxy]# apxs -c -I/usr/include/libxml2 -i mod_proxy_html.c
/usr/bin/libtool --silent --mode=compile gcc -prefer-pic -O2 -g -pipe -march=i38 6 -mcpu=i686 -DSSL_EXPERIMENTAL_ENGINE -I/usr/kerberos/include -DAP_HAVE_DESIGNA TED_INITIALIZER -DLINUX=2 -D_REENTRANT -D_XOPEN_SOURCE=500 -D_BSD_SOURCE -D_SVID _SOURCE -D_GNU_SOURCE -pthread -I/usr/include/httpd -I/usr/include/libxml2 -c - o mod_proxy_html.lo mod_proxy_html.c && touch mod_proxy_html.slo
mod_proxy_html.c: In function `proxy_html_filter':
mod_proxy_html.c:787: `XML_PARSE_RECOVER' undeclared (first use in this function )
mod_proxy_html.c:787: (Each undeclared identifier is reported only once
mod_proxy_html.c:787: for each function it appears in.)
mod_proxy_html.c:787: `XML_PARSE_NONET' undeclared (first use in this function)
mod_proxy_html.c:788: `XML_PARSE_NOBLANKS' undeclared (first use in this functio n)
mod_proxy_html.c:788: `XML_PARSE_NOERROR' undeclared (first use in this function )
mod_proxy_html.c:788: `XML_PARSE_NOWARNING' undeclared (first use in this functi on)
apxs:Error: Command failed with rc=65536
.


what is missing here ?


Sincerely
Robert B
Corey
do you have the xml2 library installed? It seems like it's missing some header files that are supposed to reference those functions. Make sure you have any -dev or -devel packages installed too.
Robert83
Hi,

the following packages are installed yum install openssl-devel openssl mod_ssl httpd httpd-devel libxml2-devel libxml2 (Hughesjr told me to install em)

but can't find what I'm missing here...

Sincerely
Robert B
Robert83
Hi,

I think I'm a $#@$@% genious [tm] smile.gif

others had this problem to... some guy with RHEL3AS ...and there someone mentioned XMLSOFT.org red hat rpms... guess what ?

ftp://xmlsoft.org/

and there ya have em all downloaded
libxml2-2.6.16-1.i386.rpm
libxml2-devel-2.6.16-1.i386.rpm
libxml2-python-2.6.16-1.i386.rpm

installed em and now I did it, it finished without any errors

now I may sleep in peace smile.gif

Sincerely
Robert B
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.