Help - Search - Members - Calendar
Full Version: Exteernal Hdd...
Linuxhelp > Support > Hardware Support
Dan
Hey

I've got a 60 gig external HDD here, and I'm not sure how to get it to work with Linux.

I looked in my fstab before turning it on, then looked again after I did, and it added this line:

/dev/sda /mnt/sda auto noautoo,users,exec 0 0

So, what I did was (as root) mount /dev/sda /mnt/sda and it gave me the error:

mount: you must specify the filesystem type.

I'm pretty new to linux, so I don't know alot. Sorry if my question was really noobish.
michaelk
Most external drives are preformated as FAT32 which in linux is a filesystem type vfat.
I would assume it only has one partition so try:

/dev/sda1 /mnt/sda vfat noauto,umask=000,users,exec 0 0

I added the umask option which will allow any user to read / write from this drive.

BTW what linux distribution are you running?
Dan
Actually it's ntfs. I formatted it when I was on windows, as I wasn't thinking I'd use Linux for a while. Now that I'm on linux, I want music, and my router is a piece of crap, so I can't just you know, DCC it to myself in IRC or anything like that.

Thanks for that, though. It worked! biggrin.gif
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.