Help - Search - Members - Calendar
Full Version: Suse 9.1 Kinternet Help
Linuxhelp > Support > Technical Support
Phaen Ilda
Hi, I've been playing on and off with Linux for a few months, and when a virus utterly destroyed Windows 2000, I decided to make the switch. I'm new to it and have only a basic understanding of the main commands of BASH.
I installed Suse Linux 9.1 without any problems on my Dell Inspiron 1100 but I'm unable to get online.
I configured Kinternet to dial up to my isp (Northnet.org, now merged with Westelcom) but the log tells me "NO DIALTONE. Connection failed"
My modem is a Conexant D480MDC v9.x and I know it works, because I also have windows XP (for a month, anyway) on the computer, and it dials up fine.
I noticed that when starting up Linux it lingers when initializing eth0 it tells me something like:
Ppp1:
ppp1:
ppp1:
15 14 12 11 10 9 8 7 6 5 4 3 2 1 0 failed
skipped

and I thought it might have something to do with it.

Also, I don't know how to switch from KDE to gnome, just a sidenote

Please, if anyone could help I would really appreciate it.
Jim
The problem is that the modem doesn't seam to be installed on your system.
Go here to grab the drivers for your modem.
http://www.linuxant.com/drivers/
Install them and you should be able to make it work. If you run into problems just come back and say "hey, I got some problems" and we will help you out.
Phaen Ilda
Hey, I got problems.
I downloaded what I think is the right file for my kernel (Though I am only making an educated guess as to what my kernel is)

hsfmodem-6.03.00lnxt04111500full_k2.6.5_7.111.5-default-1suse.i586.rpm.zip

I put the file on my linux partition and unzipped. I brought it up with the explorer and opened the .rpm file. It showed me a license agreement thing and up near the top "Install package using YaST"
I clicked on that and it installed it, and at the end of the installation it shot up a prompt saying "these packages returned an error: hsfmodem" and that's it.

Did I get the wrong file? If so, how do I find out exactly what kernel I have? If not... ?
Jim
uname -r will tell you what your kernel version is.

If you can't get the RPM to work, just get the tar.gz that will work on any system. If you don't get the RPM to work and you need help with the tar.gz let me know.
Phaen Ilda
I tried the right rpm but it returned the same error. I thought maybe the old package had been partially installed and was screwing it up. I tried rpm -e hsfmodem, but it told me hsfmodem refers to multiple packages and I suppose that means I can't use it.
Anyway, I guess I should try the tar.gz, unfortunately I have no clue what that is or where to find it =/
Phaen Ilda
Ok, disregard that last post, RPM isn't gonna work, methinks, so I'm trying tar.gz(which I found) I followed the instructions until it tells me to run 'make install'
I go to the directory and type make install and it tells me that 'make' command not found. Help?
Jim
What? make not found. Ok, um, are you running this as root? If you are running this as root and its not finding make something is seriously wrong with your system.

Try running it as root and see what happens.
Phaen Ilda
Yeah, tried it as root. Make not found. I checked /bin and make, make install, and ./configure aren't there, all of the other commands(that I know of) are there, but not those three
Phaen Ilda
Also, /root/bin is empty.
Phaen Ilda
I posted on another forum and was told it sounded like I had the 9.1 personal, which doesn't have development packages. But I wasn't told where to find these. I tried Suse's site, and no dice, anyone got a clue or a link?
pete123
Hi, did you download the suse 9.1 ISO image? If so then it is personal.

you will need the packages
GCC
ftp://ftp.gwdg.de/linux/suse/ftp.suse.com...3.3-41.i586.rpm

GCC++
ftp://ftp.gwdg.de/linux/suse/ftp.suse.com...3.3-41.i586.rpm

make
ftp://ftp.gwdg.de/linux/suse/ftp.suse.com...80-184.i586.rpm

glibc-devel
ftp://ftp.gwdg.de/linux/suse/ftp.suse.com...3.3-98.i586.rpm

binutils
ftp://ftp.gwdg.de/linux/suse/ftp.suse.com...1.1-31.i586.rpm


hope this helps, maybe also install by
CODE
rpm -ivh <packagename>


as some depend on others and it will tell you this
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.