Help - Search - Members - Calendar
Full Version: Xmms Won't Launch
Linuxhelp > Support > Technical Support
raysr
Xmms won't launch. I get this error in terminal :Gtk-ERROR **: Unable to load default font.
aborting...
Aborted
How can I fix that? I've had alot of system problems and I'm trying to get them as I find them. Thanks.
Termina
What distro are you currently using?

You might want to install (reinstall?) GTK.

What other problems are you having? Maybe they're related.
Jim
Somewhere in your GTK set up you are missing componets that are supposed to be there, like fonts. Programs wont load because they can't find the fonts.

You can either re-load GTK or you could try to isolate the elements that are you missing and load those individually. If you tell us more about your system and the problems you are having we can help you out better.
raysr
Thanks for the replies. I reinstalled xmms and it still won't load. I have several gtk files installed. Kaffeine and gxine load ok. My OS is Mandrake 9.2. I have been having considerable trouble with it. I've been using it for a year and a couple of days ago I was trying to upgrade kaffeine and it wanted another file, libXinerama.so.1 and it's been downhill since then. That file removed several others of which I didn't pay attention. My sound is all messed up, scatchy. And I get sound server message errors.http://www.linuxhelp.ca/forums/index.php?act=ST&f=10&t=5285. So I've been going through everything to see what works and what doesn't. I do have sound now but poor quality. I've used the upgrade install process to try and fix it but it still has a way to go.
Jim
A simple trick that I found to fix sound quality with xmms and alsa is to not put the volume up all the way. I found that when I put the wave or output volume all the way up, it gets really crappy. Just put them down around 75% and turn your speakers up.

Thats more of a work around, than a solutions, lets try to see what the real problem is. Run lsmod and most the output here, I want to see what modules you are running, some times there are conflicts, or maybe something isn't running that should be.
xIIx
"Thats more of a work around, than a solutions, lets try to see what the real problem is. Run lsmod and most the output here, I want to see what modules you are running, some times there are conflicts, or maybe something isn't running that should be. "

What he said... once i've had this happen to me but, I could launch xmms as root and any other user. It was something wrong in my /home/~username/.xmms directory. I trashed it and xmms fired right up.
raysr
g 35068 0 (autoclean)
isofs 28148 0 (autoclean)
udf 88736 0 (autoclean)
ppp_deflate 4472 0 (autoclean)
bsd_comp 5400 0 (autoclean)
hsfbasic2 116524 2 (autoclean)
hsfserial 26964 2 (autoclean)
hsfengine 1126348 0 (autoclean) [hsfserial]
hsfosspec 35680 1 (autoclean) [hsfbasic2 hsfserial hsfengine]
lp 8160 0
parport_pc 25544 1
parport 34472 1 [lp parport_pc]
snd-seq-oss 32000 0 (unused)
snd-seq-midi-event 6080 0 [snd-seq-oss]
snd-seq 42544 2 [snd-seq-oss snd-seq-midi-event]
snd-pcm-oss 43652 0
snd-mixer-oss 14200 0 [snd-pcm-oss]
snd-via82xx 15360 2
snd-pcm 79588 0 [snd-pcm-oss snd-via82xx]
snd-timer 18436 0 [snd-seq snd-pcm]
snd-ac97-codec 45720 0 [snd-via82xx]
snd-mpu401-uart 4704 0 [snd-via82xx]
snd-rawmidi 17760 0 [snd-mpu401-uart]
snd-seq-device 5832 0 [snd-seq-oss snd-seq snd-rawmidi]
snd-page-alloc 9044 0 [snd-via82xx snd-pcm]
snd 41380 2 [snd-seq-oss snd-seq-midi-event snd-seq snd-pcm-oss snd-mixer-oss snd-via82xx snd-pcm snd-timer snd-ac97-codec snd-mpu401-uart snd-rawmidi snd-seq-device]
soundcore 6340 0 [snd]
ppp_async 9312 1
ppp_generic 24292 3 [ppp_deflate bsd_comp ppp_async]
slhc 6564 1 [ppp_generic]
ipt_state 1080 29 (autoclean)
ipt_REJECT 3960 4 (autoclean)
ipt_limit 1560 6 (autoclean)
ipt_LOG 4184 6 (autoclean)
ip_conntrack_ftp 5168 0 (unused)
ip_conntrack 26468 2 [ipt_state ip_conntrack_ftp]
iptable_filter 2316 1 (autoclean)
ip_tables 15072 5 [ipt_state ipt_REJECT ipt_limit ipt_LOG iptable_filter]
af_packet 14856 0 (autoclean)
sr_mod 19384 0 (autoclean)
floppy 55932 0
8139too 17384 1 (autoclean)
mii 3864 0 (autoclean) [8139too]
nls_iso8859-1 3484 1 (autoclean)
ntfs 77292 1 (autoclean)
supermount 84032 2 (autoclean)
ide-cd 33956 0
cdrom 32608 0 [sr_mod ide-cd]
ide-scsi 11376 0
scsi_mod 106176 3 [sg sr_mod ide-scsi]
ehci-hcd 19212 0 (unused)
usb-uhci 25136 0 (unused)
usbcore 74988 1 [ehci-hcd usb-uhci]
rtc 9004 0 (autoclean)
ext3 60048 2
jbd 39264 2 [ext3]
I got xmms fixed by reinstalling. My sound problem isn't too bad, scatches when coming on or going off. Xmms has never worked well for me, it skips. I have another box with Damnsmall on it and it skips too. I'm going to install 10.1 Official in a few days.
Today I've been fighting xine. I can get it to connect to windoze asf but no audio. So I deleted xine and got gxine. I've read that it will play windoze asf. It's in the plugin and I have the codecs but no go. I had been trying to get that to work when everything went to sh..t on me. Thanks for the replies. It took me longer to get back here because when I reinstalled I lost everything and I couldn't remember the name of this forum.
Jim
try mplayer, thats a very good media player.
raysr
I've tried more times than I will mention to get mplayer to work. When I was successful at getting it installed, I still couldn't get anything out of it. I always had to resort to an rpm.
Maybe I'll have better luck with MDK 10.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.