Help - Search - Members - Calendar
Full Version: Sound Card Problems
Linuxhelp > Support > Hardware Support
tom boucher
I am running a dual boot system with XP and Mandrakelinux. Mandrake installed flawlessly except for the sound card. It indicated "failed". When I retried it asked whether or not it is an ISA sound card. I have an ESS1869 card and I do believe it is ISA. When ISA was selected I was prompted to enter either "alsaconf" or "sndconfig" at the command line. I am brand new to Linux and am not to familer. I believe I know where the command line is, but could not get this to work. Can anyone help with this?
tom boucher
Additional information with the sound. When I boot the system, as KDE 3.2 starts I get this message:

Sound server informational message:
Error while initializing the sound driver:
device /dev/dsp can't be opened (No such file or directory)
The sound server will continue, using the null output device.

Any help is appreciated. TOM
How old is the PC? If it is less than a few years old, the chaces of it having an ISA soundcard is very low.
tom boucher
i believe I got it in '98. It is a Compaq Presario 5240. The computer when new had Win 98. The computer is an old pig, but it has been taking to upgrades fairly well.
tom boucher
I went to the ESS website to look for a possible file that may be the issue. All they had was Windows files and a file selection titled OS/2. I am not sure whether or not that is the deal. Also, I have no idea how to download something like that in Linux, but I am researching that one. I am thinking it is a matter of getting my system to detect it. HMMMM?
I dont think OS/2 dirvers will work with Linux. You might want to try disbaling the soundcard in the system BIOS, then botting Linux. Then re-enabling it and seeing if Linux detects it when botting up. Or, try running thr hardware detction tool again. (kudzu for redhat/fedora etc.)

tom boucher
I have had problems in the past with the card and tried to disable it thourgh the BIOS. I do not think that it is possible. Each time I look into the BIOS, the option simply is not there. As far as the hardware detection tool, you mentioned the redhat/fedora....kudzo. Is that an application I can use with Mandrake 10.1? Is it in the applications for system configuration? I remember when I tried Fedora it was a matter of attempting to detect hardware. I have not seen this kind of option in 10.1. If so, where might I find it? Forgive the how to questions, I am an extreme Linux novice and I am on the road at work and will not be able to get at my machine until tomorrow night.
tom boucher
I was actually able to get alsaconf to work. Now it is a midi issue, i think. Here is the card setup: E/A port= 0x220, IRQ=5, DMA=1, MPU-EA= 0x330. I know this because of when it was configured. As to where to find it now, I have no idea.
The issue is that it plays the test sound in KDE Sound System file. Computer .wav files and the system bell do not test or play. Music CDs do not play. Also, "test Midi player" under KDE Sound System does not do anything. When I look at the hardware tab under KDE sound system, it is on auto detect, and no selection of a midi device is possible. Any ideas?
tom boucher
No midi is listed in the hardware unerder KDE 3.2 Sound System. Should I install Pmidi or Kmid or something similar?
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2018 Invision Power Services, Inc.