Help - Search - Members - Calendar
Full Version: Bootloader Troubles
Linuxhelp > Support > Technical Support
Cheator
Hey guys. I think I need some help.

I installed Fedora Core 2 on my system. IT has windows on it and I just installed it on my hdc so I cna get more of a feel for linux (You can only go so far with knoppix...). So I installed it, and it was al ittle messy. IT used the non-graphical instlal and all (I have an X800 and no distro lieks that card). But I installed it nad it was fine. But when I went to boot windows again to get some drivers.. it wouldn't go.

It froze with the screen saying sometihng like this:

Booting "Windows XP'

rootnoverify (hd0,0)
chainloader = (hd0,0)+1

It does nothing after that. I;ve tried many variations on that configuration. chainloader +1, root (hd0,0), etc.. but nothing works. Linux boots fine but it just does not boot windows.

I googled this thing for about 4 hours. I found people with my issues but the way to resolve it was never what worked for me.

Am I doing something wrong here?
Corey
Try this configuration in your grub boot config:

title=Windows XP
root (hd0,0)
makeactive
chainloader +1


that should work provided that the XP boot files are on the first partition of your first drive.
Cheator
Actually I tried tihsd configuration,. IKT restarts the computer...
Cheator
Oops. I was wrong. IT doesn't reboot. But when I use your suggested configuration but chainloader = (hd0,0)+1 it reboots. This configuration does the same as the first and freezes onscreeen and doesn't move beyond that point.

Btw I guess I should tell you my setup. I have windows on my hda, I have an hdb that has files on it and an hdc conected by a drive caddy on the secondary channel as the master. Not sure if this will help at all.
Jim
Try using this for you grub entry.

CODE
title=Windows XP
rootnoverify (hd0,0)
makeactive
chainloader +1


You need to get rid of your line "chainloader = (hd0,0)+1" because thats not a valid grub order, I don't know why its getting through. Replace your windows entry with the code above and it should work. If it doesn't post your entire grub.conf file.
Cheator
I did try that though. As well as correy's. It still does not move sad.gif
Jim
There very well might be something wrong with your windows then. Either one of those should work and why they aren't is beyond me. Let me look into some stuff for you, but I think you might be facing a problem with windows, not grub.
Cheator
Thaknsfor the hepl. I hope its not windowsnad wouoldn't think itis.All I did to it was get rid of it's bootloader. I am also lookingstill,but Ican't findanything. Aparently lots of people have my problem but they getasolution Ican't.
Jim
You could always try to re-install grub. Something may have gotten mixed up when it wrote to the MBR on the primary drive. Just open a CLI and enter the command grub you will then get a new prompt enter these commands
CODE
grub> root(hd1,0) //where your boot partition is, the partition that has /boot on it.
grub> setup (hd0) //sets grub up on the MBR of your primary drive
grub> quit


That will simply re-install grub onto the MBR of your primary drive and it may or may not help at all, but at least it eliminates one problem.
Cheator
Aye thank you for the suggestion though I had reinstalled about 3 times. Infact I used FIXMBR in the windows recovery mode from the windwos XP CD and of course it did nothing but ERASE all bootloaders and couldn;t start an OS... I hate windows
Jim
Ok, so what I don't get here, is this isn't a Fedora Core issue because grub should be the same no matter what. The whole grub package may be currupt. You may need to re-install grub completely (not just the MBR) and probably want to get it from somewhere other than Fedora.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.