Help - Search - Members - Calendar
Full Version: Help: How To Enable Usb Flash Drives?
Linuxhelp > In The Community > General Discussion
rina
How to enable USB Flash Drives?

Please guide me.

Thanks

rina
xsist
Ok im assuming you have acces to a command line....

1st we must edit the fstab file to allow you to mount the drive...

To do this open up you editor of choice (logged in as root!) and open th fstab file. (usually /etc/fstab) then we need to add a new entry so go to a new line and add this to it ....

/dev/sda1 /USB_KEY vfat noauto,owner,dev,exec,suid,user 0 0

This allows you to mount the drive...

2nd we need to do a test mount.. open the console and type

mount /dev/sda1

Now open the filesystem and go to /USB_KEY if its there then it worked.

3rd we need an easier way to acces it, I know gnome will auto a link into the ///computer . but this is for if there isnt one..

Create a new launcher, and give it a name and an icon, for the code use mount /dev/sda1 then test it..

if it all works then your done....


hope this helps..

HAPPY TWEAKING..
rina
Thank U. I will try. Hope ur suggestion will work.

Thank U again.

rina
michaelk
You will need to create the directory prior to mounting the flash drive.

Depends on the linux distribution but most use the /mnt or /media for removable media.
mkdir /mnt/usb

Change the directory name (usb) to your choosing.

Also add the umask option to allow users to read / write.

dev/sda1 /mnt/usb vfat noauto,user,umask=000 0 0
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.