Help - Search - Members - Calendar
Full Version: /etc/mtab
Linuxhelp > Support > Technical Support
KnightMare
All the sudden when i boot linux i get errors at startup. Can't load /etc/mtab Permission Denied.

I logged in as root and tried to chmod 755 it, but i got permission denied.
Tried to just open it to look at it, Permission denied.

Anyone have any ideas how to fix? It's starting to irratate me....

Oh, and also tried the "Last Stable" i have in Lilo... Same thing.
KnightMare
I am thinking a corrupt file system here. Anyone else use the Reiserfs file system?
chrism01
well, should be a text file, similar to /etc/fstab. If you can cat it ok , then you can copy the contents to a temp file eg

cat /etc/mtab >/etc/mymtab

then check perms. Should be -rw-r--r--. Set /etc/mymtab to this. Then

rm /etc/mtab

mv /etc/mymtab /etc/mtab

BTW, you have to be root to mess with anything in /etc. You may also need to use the chattr cmd (man chattr) to enable you to do this.
Good Luck

wink.gif
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.