Help - Search - Members - Calendar
Full Version: Help With Red Hat 8.0 Rpms
Linuxhelp > Support > Technical Support
jakn0
I have just installed redhat 8.0, I have just noticed that it doesn't include pico or pine. Whenever I try to install something via RPM it comes back telling me that it needs a dependency (usually something starting with lib). When I try installing that dependency, I am told that dependency needs a dependecy. Help would be most grateful
chrisw
you have to keep installing dependencies to satisfy the situation...
to install a dependency for another rpm...you have to install them at the same time usually.
for example:
a.rpm depends on b.rpm

so you would install them both using the following

rpm -ivh a.rpm b.rpm

and if b.rpm then needs a dependency...just add that rpm after b.rpm in the previous line starting with 'rpm -ivh.....'

rpms are such a b!tch sometimes

hope this helps
chrism01
I find that registering with RH solves this. I think the 1st system is free ?
Anyway, all you have to do is load eg pico from CD and then run up2date. This tool not only updates
you to the latest ver inc patches, but automatically updates any dependencies also.
Sorted.. smile.gif
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.