Help - Search - Members - Calendar
Full Version: 3.5 In. Floppy Drive
Linuxhelp > Support > Hardware Support
It is mounted but I can't read or write to the floppy drive. I have a linux file on the floppy disk and I also tried a floppy with a windows text file. Everything is ok in windows 98. When attempting to read or write the drive activity lights comes on and I hear the clicking sounds as the drive is working. It usually keeps on running like that until I close down the floppy directory window(which is empty) Sometimes I get an error msg "medium not found". If I try to make a boot floppy in linux I get the error "selected image doesn't exist on installation medium". I'm thinking the fstab file is not correct. The fstab file is:

/dev/hda3 / reiserfs acl,user_xattr 1 1
/dev/hda1 /windows/C vfat users,gid=users,umask=0002,iocharset=utf8 0 0
/dev/hda2 swap swap pri=42 0 0
devpts /dev/pts devpts mode=0620,gid=5 0 0
proc /proc proc defaults 0 0
usbfs /proc/bus/usb usbfs noauto 0 0
sysfs /sys sysfs noauto 0 0
/dev/cdrecorder /media/cdrecorder subfs fs=cdfss,ro,procuid,nosuid,nodev,exec,iocharset=utf8 0 0
/dev/dvd /media/dvd subfs fs=cdfss,ro,procuid,nosuid,nodev,exec,iocharset=utf8 0 0

/dev/fd0 /media/floppy subfs fs=cdfss,rw,procuid,nosuid,nodev,exec,iocharset=utf8 0 0
/dev/hdd4 /media/zipdos subfs fs=cdfss,rw,procuid,nosuid,nodev,exec,iocharset=utf8 0 0

Can someone straighten me out? I know I broke something and probably got the listings in the fstab file all hosed.
I forgot to add that I can do a fdformat on the command line.
Talk about a mind blower (at least it's blowing my mind). I tried another floppy disk that is ibm formatted (ibm dos right?). I am able to read and write to this floppy in linux. I can also read and write to a floppy formatted with msdos with vfat files on it. But as I said in my original posting, I have tried other floppy disks with vfat files and linux files and they do not work in linux; but they do work in windows. Can someone explain why out of 4 floppy disks, only two work in linux, but they all work in windows? Also I formatted one of them in linux and it still didn't work ( a new out of the box floppy disk). My fstab file has the following listing that I copied from something I got on the internet:

/dev/fd0 /media/floppy subfs fs=floppyfss,procuid,nodev,nosuid,sync 0 0.
I forgot to say, the error I get is "no medium found" on the floppies that don't work in linux. thanks.
I just tried 6 more floppy disks (older ones as well) and they all worked in linux. So I guess there is just something marginal with the two disks that do not work in linux. I apologize for wasting everybody's time with this nonsense.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2018 Invision Power Services, Inc.