Help - Search - Members - Calendar
Full Version: Problems Installing Src.rpm File
Linuxhelp > Support > Technical Support
kilahchris
Im running redhat 8 , and im trying to install this src.rpm file??/ however when i follow the instruction on that says to type rpm --rebuild <filename.src.rpm> console reports --rebuild not a know command. I also tried rpmbuild -rebuild <filename.src.rpm


__________________
Corey
In newer versions of RPM, in order to rebuilda src. package, you have to issue the following command:

QUOTE
rpmbuild --rebuild filename.src.rpm


This information can be obtained through "man rpmbuild" or "man rpm".
chrisw
i had that same problem.....why cant they just keep things consistant....
damn Redhat
kilahchris
[QUOTE] rpmbuild --rebuild filename.src.rpm [QUOTE]


I had first tried that command... and console reports uknown command???
chrism01
2 possibilities come to mind:

1) do this as root user

2) make sure that's 2 dashes/hyphens in front of the rebuild option;
most options are only preceded by 1

HTH
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.