Help - Search - Members - Calendar
Full Version: Error Loading Operating System
Linuxhelp > Support > Technical Support
herrard
I wanted to make my computer a dual boot system. Originally, I had SuSe 9.1 intalled. I decided to reinstall Windows so I reformatted the entire hard drive since I found out the Windows requires itself to be installed first. I went through the Windowns installation process but I get the message "Error loading operating system" when the system reboots. I've tried reinstalling a couple of times and I get the same message.

Could it be that Windows could not properly install because of SuSe 9.1 modifying Grub?


Thank you.
pwmort84z
Which version of windows are you installing? And what is the file system? If it is Fat32, you may not have set your primary partition (C:) to the active partition. This can be changed with a windows boot disk, and running "fdisk".
Jim
Its also a myth that windows has to be installed first. Windows will write over your bootloader if you install Linux first, but you can replace the boot loader with out re-installing linux.

In general, if your going to install both at the same time, do windows first, but you don't have to trash your linux system just to install windows.
herrard
It's only a myth... wow that sucks for me. Thanks for the info tho

I'm installing Windows XP Pro.. I've tried to do reformat it first with fat32 and it didn't work. Afterwards, I tried to reformat the drive to ntfs and it still doesn't work. The funny thing tho is that when I try to reformat the drive to ntfs.. the message "Error loading operating system" becomes "Missing operating system" instead.

I didn't mention before that I'm installing Windows with a Windows XP Pro Upgrade CD... I have a full version of Win98 and so the XP CD being only an upgrade cd shouldn't affect the installation in theory. Can it be that the upgrade CD can't be installed because Win98 isn't in the drive? Do I need to reinstall Win98?
Jim
I don't think its the install, I think somehow its trying to boot to the wrong drive.

Are you running into this problem before or after you install Grub. I gather its before.

So just for clarity, you put in the windows CD, go through the steps to install a new copy of windows onto a cleanly formated partition (make sure its a primary, not extented), it reboots, its comes back to the install, finishes, and when you reboot to enter windows you get a NO OS error?

Ok, this is just wiered, tell me what your partition scheme is, because I think thats where the issue is. Also, make sure you hard drives are set up correctly (ie, master on master with the jumper set to master....)
herrard
Right now, I don't really have a partition scheme.. I've been formating the whole drive ntfs and installing. I figured that SuSe 9.1 can resize nfts anyway so it should be fine.

I've tried this scheme before (I have a 120 gb maxtor sata):
Drive C 32gb FAT32 Windows
Drive D 32gb ext3 /
Extended>
Drive F 1gb swap
Drive G everything else FAT32 (for storage)

I have an K8N Platinum... nforce 3 250 gb mother board if that helps.

I'm not in front of my computer now so I'll check the jumper later.

Thanks.. I really appreciate the help
Jim
Don't trust SuSE to do the NTFS re-size. It can do it, but its a risk that it might screw it up. So do this.

Lets start by getting your windows system to book. Decide how much space you want for windows and when you install it, make a new partition, thats the 1st primary partition on your master drive. Linux notation calls this hda1, windows notation (C:/ D:/ ect...) really has no bearing on partition number, so I will use linux notation for the rest of this.

Format the partition to a size, say 20 gigs (this is your call) and install windows on it. Leave the rest of the space un-partitioned. Go through the whole install and make sure that you don't get any errors. Make sure you are making a compleatly new partition on the drive. Record any errors you get and let me know. Ounce we get the windows drive up we will start to work on the linux drive.
herrard
I'll try that.

btw, I checked the jumper of the hard drive and it seems correct. I reinstalled linux after i checked the jumper just to make sure that the hard drive still works.. I tried Fedora and it installed so it seems that there is something wrong with windows. although i have to tell you that fedora wouldn't load unless i put "nousb" before i boot.
pwmort84z
I'm not sure if this will help or not, and I'm not trying to insult anyone, haha, but your motherboard can boot from a USB drive, so make sure you dont have a USB drive plugged in somewhere... Just making sure no one overlooks the obvious
herrard
no i have nothing attached to my usb ports but the linux setup still freezes unless i put "nousb" I've tried this with a gentoo livecd.. same thing.. i need to put "nousb" for the setup to even start. I've also tried it with Mepis and it too required me to put "nousb".. I'm thinking it must be my motherboard or something because i don't understand why i need to put "nousb" everytime


Jim: I still can't get Windows to start. I repatitioned the drive 32gb ntfs and the rest i left unpartitioned... Now I'm getting "Error loading operating system" again... I was getting "Missing operating system" before. but i figured out that my MBR was screwed up that's why i'm getting the "Missing operating system".. I fixed it now by using fdisk /mbr and reinstalling Windows but now I'm back to getting "Error loading operating system"

Can it be my bios? I'm afraid to flash it because it seemed that the hard drive works for linuxes since they modify grub but that's it. Can't Windows edit grub also?
Jim
Are you loading Windows from grub or with the windows boot loader? If you are, post the entry for windows.

Have you ever installed windows from this CD before? Is it a "real" copy or a burned disk, because if its a burned disk, there could just be something wrong with the disk
herrard
I did it. Finally. Thank God!

(My CDs are authentic and I've used them before and they worked fine up until I started installing linux)

I'm not sure how it happened... I still can't figure out... maybe you can

I used fdisk /mbr and then used Microsoft's recovery console's FIXMBR and FIXBOOT

then I installed FreeBSD.. as before like linux, this os loaded just fine but this time I told it to not install its own boot loader. After successfully installing FreeBSD, I attempted to install Windows--and it worked! I have no clue why because I've done this with Fedora too.. telling it not to modify the MBR with its boot loader and Windows still wouldn't load after reboot.


Anyway, Thanks Jim. You've been a lot of help. Thanks for being so patient.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.