Help - Search - Members - Calendar
Full Version: Mandrake Linux Freezes On Boot-up
Linuxhelp > Support > Technical Support
I recently installed Mandrake Linux 10.0, and tried to load the new nvidia driver. To do this, nvidia says you need to start the computer with only a command prompt, so I did that. After installing the driver, every time I would boot back into kde (using the commands xinit, then kde), my desktop would freeze immediately after the splash screen went off from kde. I later noticed it also happened occasionally when I booted in a command prompt too. Hitting ctrl-alt-del from in kde did nothing, however hitting it under the command prompt gave me an error that says PID 1911 (ID1) was hung up (or something like that). Does anyone have any suggestions?

Thanks for the help,

After rebooting the computer several times and running a memory test (Memtest 86 said my memory is fine), I was able to get into kde breifly, to change the startup to load kde automatically. After changing that, I opened the internet client, typed in, and it froze again. I rebooted the machine, and was put back into the command prompt, after the screen flashed a few times. So, I typed xinit, and I got this error:

Using config file: "etc/X11/XF86Config-4"
Using vt7

(EE) NVIDIA(0): Failed to initialize the NVIDIA kernel module!
(EE) NVIDIA(0): *** Aborting ***
(EE) Screen(s) found, but none have a usable configuration.

Fatal server error:
no screens found.

If anyone has any ideas to help me with this problem, please let me know.

NOTE: This problem all started when I tried to update my NVIDIA GeForce 3 Ti driver to the newest version (using the nvidia website download for linux). If anyone knows of a way to undo that update, that could help.

Thanks again for any help or ideas,
Try rolling your driver back to nv instead of NVIDIA and see if that fixes the problem. Actually, that wont really fix the problem as work aroud it for now.

Something went wrong in you nvidia install, and we need to figure out what. For now, just change the driver for you display to nv see where that gets you.
I tried to change "nvidia" to "nv" using vi, while logged in as root, and saved the changes. However, after a reboot, driver problem still happened, so I checked /etc/X11/XF86Config-4, and the changes I made did not stay the same, they changed back to "nvidia". To make sure the ":w!" command was working right in vi, I changed the device name as well as "nv" and restarted. The device name stayed how I changed it, however "nvidia" came right back. Is there anything in the startup that would change the setting back to how it was?

Thanks again,
I also just tried to use "vesa" as my video driver, but that also will not work. It goes to kde briefly (about 2 seconds) then back to command prompt. It lists errors that say it cannot redefine the space bar, backspace, or any other button becuase of conflicts.
vesa probably wont work. You should try to remove the nvidia driver form /etc/modules.preload or it may just be called /etc/modules either way, it will just be a simple text file with a few modules listed on individual lines. Find the line that says nvidia and comment it out or remove it. Then change the XF86Config file to nv and see what happens.

You also don't have to re-boot. Do this. Change the line to "nv" and type startx and see what happens.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2018 Invision Power Services, Inc.