Help - Search - Members - Calendar
Full Version: Can Write To Fat With Root Only
Linuxhelp > Support > Technical Support

I bought a second hard drive and formatted it as FAT so I could use that drive to read/write with Linux and Windows.

I can only write to it as root though. I've tried changing the permissions of the mount folder in su mode but it says I have insufficient permissions to change the permissions.

this is what I have in fstab:
/dev/hdb1 /gandalf vfat user,rw 0 0

You can not change permissions of the directory when it is mounted.
To allow all users have read / write permissions add the umask option to the fstab entry.

/dev/hdb1 /gandalf vfat users,umask=000 0 0
Thanks very much! That did the trick.

This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2018 Invision Power Services, Inc.